VIDEO PROBLEM ON NOKIA E63

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

VIDEO PROBLEM ON NOKIA E63

Post by edo87 » Sun Jan 16, 2011 7:34 pm

Hi Guys,
I just installed ScummVM v-3 on my Nokia E63.
I noticed two things:
1: I have actually two SCUMMVm programs in my applications directory: ScummVM1 and ScummVM2... why? is it normal.
2: When I open ScummVM the cursor is locked on the top left of the screen and the video begin flashing coloured dots every two-three seconds, so the program does not work...
Any suggestions/ideas?
Thanks,
Edo

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sun Jan 16, 2011 7:59 pm

Video could be a operator specific version of the E63 (pre installed software) which is causin the video issue. To enable controls, press green, then press M on your keyboard, green again.

edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

Post by edo87 » Tue Jan 18, 2011 9:47 pm

Hi,
it seems that it's a common problem:
http://www.youtube.com/watch?v=4TqZxyGb81o
Is there any way to solve it?
Thanks a lot.
Edo

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Jan 19, 2011 11:38 am

I know that some has been factory resetting their phones, some have started the video app or so. Just so it changes screenmode to a more compatible one. What happens now is that the phone is rendering 16 bit graphics in a hi color format buffer (not my fault). And thus all colours and stuff look funny.

edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

Post by edo87 » Thu Jan 20, 2011 8:28 am

what do you mean with start video app?
I tried to delete all the crap programs i had, the only thing i have now is skype and gmail but when they are closed the shouldn't cause any problem.
I've been looking for a program to change the screen mode, the number of colours, the video settings and so on but i didn't find it.
I don't have any other idea, i don't know how the source code is, but there is not a way to compile it with different video settings?
Otherwise i'm just gonna give up... Very sad.

edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

Post by edo87 » Thu Jan 20, 2011 9:38 am

just another update: i've tried to factory reset my phone but it didn't work

edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

Older Versions Tried

Post by edo87 » Tue Feb 08, 2011 3:50 pm

Hi Guys, I've tried some of the older versions of ScummVM on my nokia E63 phone: that's the logbook

nw=not working

1.1.1 nw(video)
1.1.0 nw(video)
1.0.0 nw(video)
0.12.0 nw(rotated 90°, video, no control)
0.13.1 nw(rotated 90°, video, smaller, no control)
0.8.2-v2 installation not supported
0.8.2-v1 installation not supported
0.11.1 nw, same as 0.12.0
0.9.1-v1 and 0.9.1-v2 installation not supported
0.9.1-v3 expired certificate!
0.10.0 expired certifiate!
0.11.0 nw (video, rotated 90°)

With video i intend the colours problem stated in previous posts.
No control means that there's no way of controlling the mouse.

Post Reply