The Gourd of the Beans

AGI, SCI, Wintermute, Sludge engines fangame creation discussion

Moderators: ScummVM Team, AGI moderators

Post Reply
User avatar
klownstein
Posts: 8
Joined: Thu Dec 16, 2010 6:23 pm
Contact:

The Gourd of the Beans

Post by klownstein » Thu Dec 16, 2010 10:36 pm

I've been working on this project, The Gourd of the Beans, off and on for a number of years. I've recently recruited some helpers to speed along the work and hope that they will significantly help speed my progression. I have a new website:

https://sites.google.com/site/klownstein/

where I hope to keep some relatively up-to-date info so all those interested can be informed of the progression. For those who have been following my work, check out the site and let me know what you think.

-klownstein

User avatar
MusicallyInspired
Posts: 992
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired » Fri Dec 17, 2010 12:09 am

That looks really interesting. And fun!

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Sat Dec 18, 2010 4:53 am

Looks really good. I've just added your site to my links page on www.agifans.com. Any chance I can convince you to switch to using the new PICEDIT for creating the picture resources?

User avatar
klownstein
Posts: 8
Joined: Thu Dec 16, 2010 6:23 pm
Contact:

Post by klownstein » Sat Dec 18, 2010 9:57 pm

lance.ewing wrote:Looks really good. I've just added your site to my links page on www.agifans.com. Any chance I can convince you to switch to using the new PICEDIT for creating the picture resources?
I've downloaded it and plan on giving it a go on my next background. :)

-klownstein

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Sat Dec 18, 2010 11:07 pm

Thanks. Let me know of any features you would like to see added.

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Sun Dec 19, 2010 10:31 pm

I have to apologise in advance. I'm guessing you haven't started on that next AGI picture yet, but I've found a bug that is fairly big really. It actually generates a non-standard AGI picture. If you set the visual colour to white, it is currently adding colour 16 into the picture code buffer. It will do the same thing if you set the priority colour to red.

This bug was introduced with one of the last features I added, which was the background image tracing feature. It might seem like a fairly weird bug but it is due to the way I keep track of the transparent colour. White is transparent on the visual screen and red is transparent on the priority screen.

It's a quick fix to fix this issue, so I'll update it now and release beta 2. Note that this fix will not have any of the newer features I've been working on since those are not fully tested yet. The beta 2 release will be exactly the same as beta 1 except that it will include this fix.

I'll report back when beta 2 is uploaded to my site.

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Sun Dec 19, 2010 10:44 pm

ARGGGGHHHH!! I just found an even bigger bug. A much, much bigger bug. The set priority colour and turn off priority colour actions are adding the wrong codes to the picture code buffer. They are adding the corresponding visual colour codes instead, e.g. set priority is actually setting the visual colour (not that you notice until you load and save the picture).

Classic copy and paste error.

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Sun Dec 19, 2010 11:11 pm

And a third bug. Not quite as bad this time but picture navigation is not the best when on the priority screen. It keeps switching to the visual screen.

I'll fix all three bugs while I'm at it. Not sure why I didn't see any of these until now.

lance.ewing
Posts: 56
Joined: Sat Dec 11, 2010 8:11 pm
Location: www.agifans.com
Contact:

Post by lance.ewing » Mon Dec 20, 2010 12:08 am

I have just uploaded beta 2 to my web site. Grab that version to draw your next picture with.

Post Reply