ScummVM Channel FINAL - IOS58 Support / SVN / Download Now!

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

User avatar
Mr_Nick666
Posts: 146
Joined: Wed Apr 11, 2007 9:59 am
Location: Bideford, Devon, UK
Contact:

ScummVM Channel FINAL - IOS58 Support / SVN / Download Now!

Post by Mr_Nick666 » Fri Nov 26, 2010 9:14 am

Image

Image

Youtube video here.

App: ScummVM Forwarder
App Description: The forwarder will attempt to load (in this order):
sd:\apps\scummvm\boot.elf
sd:\scummvm\boot.elf
sd:\apps\scummvm\boot.dol
sd:\scummvm\boot.dol
usb:\apps\scummvm\boot.elf
usb:\scummvm\boot.elf
usb:\apps\scummvm\boot.dol
usb:\scummvm\boot.dol
Channel Name: ScummVM
Channel ID: SCUM
Blocks: 13
Type: Animated (brlyt file customised by wilsoff and graphics by Mr_Nick666)
Forwarder: Tantric
Wii Settings: Working
SDHC Compatible: Yes
Tested by: Mr_Nick666/wilsoff/Tantric

What's new?

NEW logo!
Fixed widescreen stretching of some characters.
Fixed widescreen on splash loading screen.
Channel now titled ScummVM.
IOS58 support (thanks to Tantric)
Support for Nightly Builds.
Other minor things!

Mediafire: Download

Please uninstall any older version of this Channel as it has the same ID, but uses a different IOS. If you try and just over install it it will stop and give you an error. :shock:
Last edited by Mr_Nick666 on Thu Jan 06, 2011 3:08 pm, edited 4 times in total.

User avatar
md5
ScummVM Developer
Posts: 2258
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Fri Nov 26, 2010 10:04 am

The video looks nice :) well done!

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Fri Nov 26, 2010 10:06 am

But why does this still use our *old* logo? :-(

User avatar
Mr_Nick666
Posts: 146
Joined: Wed Apr 11, 2007 9:59 am
Location: Bideford, Devon, UK
Contact:

Post by Mr_Nick666 » Fri Nov 26, 2010 10:13 am

fingolfin wrote:But why does this still use our *old* logo? :-(
That damndable big S!! I didn't realise it had changed... I'll edit the Channel and replace it. Totally missed that one. :roll:

Download removed until it's sorted... (the ever present danger of including the word "FINAL" in a title...) :shock:

User avatar
KainXVIII
Posts: 42
Joined: Mon Feb 11, 2008 10:00 pm
Location: Russia

Post by KainXVIII » Mon Dec 06, 2010 4:00 pm

Waiting..again :twisted:

Brainworm
Posts: 1
Joined: Mon Dec 06, 2010 8:32 pm

Post by Brainworm » Mon Dec 06, 2010 8:33 pm

Need it please!!! :twisted: :twisted:

raschi
Posts: 45
Joined: Mon Jan 23, 2006 6:57 pm

Post by raschi » Tue Dec 07, 2010 5:03 pm

Yeah, what a tease;)

User avatar
Red_Breast
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast » Tue Dec 07, 2010 6:50 pm

I'd get your money back guys if I was you. Disgraceful public relations team you have Nick :wink:

obcd
Posts: 19
Joined: Tue Nov 09, 2010 10:09 am

Post by obcd » Tue Dec 07, 2010 9:44 pm

I am having a strange issue when I am using the forwarder (still the one with the little s). If I launch the scummvm boot.dol from sd:/apps/scummvm, everything works fine. If I launch it from the usb1:/apps/scummvm, The program fails to mount the usb harddisk. Due to that, it can't find scummvm.ini, and I am unable to add a game from the harddisk. I was wondering if someone else experiences the same issues, and if there is a fix for it before I digg deeper into the problem.
If I launch the program with the homebrew channel, the same happens. If I launch it with wiixplorer, everything works fine. So, it's not specific related to the forwarder, but I was hoping that Nick might have some ideas after he finished answering his fanmails. :)

raschi
Posts: 45
Joined: Mon Jan 23, 2006 6:57 pm

Post by raschi » Wed Dec 08, 2010 4:54 pm

obcd wrote:I am having a strange issue when I am using the forwarder (still the one with the little s). If I launch the scummvm boot.dol from sd:/apps/scummvm, everything works fine. If I launch it from the usb1:/apps/scummvm, The program fails to mount the usb harddisk. Due to that, it can't find scummvm.ini, and I am unable to add a game from the harddisk. I was wondering if someone else experiences the same issues, and if there is a fix for it before I digg deeper into the problem.
If I launch the program with the homebrew channel, the same happens. If I launch it with wiixplorer, everything works fine. So, it's not specific related to the forwarder, but I was hoping that Nick might have some ideas after he finished answering his fanmails. :)
Install ios58 perhaps?

obcd
Posts: 19
Joined: Tue Nov 09, 2010 10:09 am

Post by obcd » Wed Dec 08, 2010 9:39 pm

Thanks for the suggestion.

My HBC 108 says that it is running on IOS58 V24.31.

So, I assume that the IOS is installed.

I also notice that the forwarder takes a long time to load the scummvm boot.dol, while wiixplorer launches it very fast. Maybe wiixplorer is caching the disc, but I doubt it.

I almost think that the forwarder is using USB 1.1 and wiixplorer USB 2.0

HBC is supposed to use IOS58 as well. The load times are also slow when I use it to launch the scummvm boot.dol.

I have no idea where to start looking for the differences between those different methods to launch homebrew.

raschi
Posts: 45
Joined: Mon Jan 23, 2006 6:57 pm

Post by raschi » Wed Dec 08, 2010 11:39 pm

Are you using the new forwarder which was removed, or the old one?
If you are using the new one, it shouldn't be necessary to rename boot.elf to boot.dol.
If you are using the old forwarder, you must rename boot.elf to boot.dol. Do not "convert" to boot.dol

obcd
Posts: 19
Joined: Tue Nov 09, 2010 10:09 am

Post by obcd » Wed Dec 08, 2010 11:55 pm

It might be a stupid question, but how do I know which version of the forwarder I am using?
I just checkd with the HBC, and it seems to load the program faster as well. The program is just having problems to access it's boot disk when I launch it like that. Besides that, I don't like my daughter to mess around with the HBC, as it can be used to launch dangerous applications like the wadinstallers as well.

If the scummvm file would be in the wrong format, would it still launch with the forwarder?

raschi
Posts: 45
Joined: Mon Jan 23, 2006 6:57 pm

Post by raschi » Thu Dec 09, 2010 1:45 am

Try this:

Download and run WiiMC ios 202 installer 1.1 (google)
Download newest ScummVM 1.2.0, extract to SD and make a copy of boot.elf. Rename this copy to boot.dol so that you have both boot.elf and boot.dol in scummvm folder.

Hopefully this should work.

edit: Yeah I see what you mean now with boot.dol on usb.
The old forwarder doesn't play nice with boot.dol on usb for me neither. Works fine from HBC though.

You really should just wait for the new forwarder:(

User avatar
Red_Breast
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast » Fri Dec 10, 2010 9:06 pm

Wasn't that WiiMC ios 202 a custom ios to unlock USB 2.0? The one made by KWiirk? Just trying to find it on Wiibrew I see the page has been deleted.
Team Twiizers recent addition of USB 2.0 is much more elegant as it uses Nintendo's USB 2.0 which had been introduced with one of the balance board games.

Post Reply