ScummVM 1.2.0 and Nokia E63

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
DarkSorceror
Posts: 2
Joined: Tue Nov 02, 2010 6:41 am

ScummVM 1.2.0 and Nokia E63

Post by DarkSorceror » Tue Nov 02, 2010 6:48 am

I've installed ScummVM 1.2.0 on an E63 and it doesn't load: it flashes the screen black then drops back to the applications menu. So far, the only information I've found is that it should run, given that it's S60 3.1 edition. Any ideas?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Nov 02, 2010 12:31 pm


DarkSorceror
Posts: 2
Joined: Tue Nov 02, 2010 6:41 am

Post by DarkSorceror » Wed Nov 03, 2010 5:32 am

Thanks, Anotherguest. That one works! :) Loving the Symbian port! You've done awesome work.

The installer said it was installing v1.12 though; is that a packaging error?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Nov 09, 2010 8:00 am

yes its only a packing issue. I.e me setting the wrong version in the pkg file. sorry for that.

otoluk
Posts: 1
Joined: Fri Dec 17, 2010 11:09 pm

Post by otoluk » Fri Dec 17, 2010 11:12 pm

Thanks. Works now on Nokia E66 too.

Chrille
Posts: 1
Joined: Thu Dec 30, 2010 4:18 pm

Post by Chrille » Thu Dec 30, 2010 4:22 pm

It's a great port. Why isn't this version posted on the main site?

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Thu Dec 30, 2010 5:10 pm

Good question... We *do* offer a "Symbian S60 version 3 binary " binary for ScummVM 1.2.0 on our main website -- and it was made by Anotherguest, too. And it seems to be different from the version Anotherguest posted above... I'd like to know how that comes...

And I hope that Anotherguest will also get around to providing working Symbian binaries for 1.2.1, too :).

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu Jan 13, 2011 9:02 am

yeah.. 1.2.1 is on the ropes, just holidays, work and life in the way. :-) But now I'm back :-) Want to do that two exe version also. :D

edo87
Posts: 7
Joined: Sun Jan 16, 2011 7:29 pm

Post by edo87 » Sun Jan 16, 2011 7:44 pm

Still not working for me...

lisa9
Spammer
Posts: 4
Joined: Fri May 24, 2013 5:46 am

Post by lisa9 » Fri May 24, 2013 5:49 am

I think its all over now.

digitall
ScummVM Developer
Posts: 963
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Fri May 24, 2013 11:27 am

A few points...

1. The latest Symbian Release is v1.4.1 which is slightly outdated, but can be found on the download page:
http://www.scummvm.org/downloads/#older

2. If this still exhibits the problem, then I'd suggest (as our Symbian porters have not provided any newer builds and the buildbot doesn't produce SymbianOS builds), that you should compile this yourself. Instructions for doing this are provided on the Wiki at:
http://wiki.scummvm.org/index.php/Developer_Central
specifically:
http://wiki.scummvm.org/index.php/Compi ... VM/Symbian

digitall
ScummVM Developer
Posts: 963
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Fri May 24, 2013 3:04 pm

Ah, one of the SymbianOS porters, anotherguest has provided a v1.6.0git build here ahead of the official v1.6.0 release for testing:
http://anotherguest.blogspot.co.uk/2013 ... pdate.html

Please feel free to download and test.

Post Reply