version of devkitpro needed to compile 13.1

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
plover
Posts: 2
Joined: Thu Jul 02, 2009 9:34 am

version of devkitpro needed to compile 13.1

Post by plover »

Hi, I am trying to compile the DS version on Ubuntu 9.04 and am running into compile problems. I think the issue is that I am not using the right version of devkitPro but can't seem to find any info about which version I should be using.

Compiling and running the normal version of scummvm on ubuntu works fine. I can compile the nds examples included with devkitPro fine as well. I am using the devkitPro from sourceforge and the trunk version of scummvm checked out yesterday at rev 42015

I am doing the command:

make SCUMM_BUILD=f

and am getting the error
scummvm/backends/platform/ds/arm7/source/main.cpp:588: error: 'SOUND_CR' was not declared in this scope.

Can anyone point me at the right version of devkitpro and/or the correct version of scummvm to try compiling with?

Also, do people typically use linux to compile the DS version? Are there problems with building it on linux, should I switch to windows?

Thanks

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin »

Devkit r24 works for me on OS X. I don't think building works better; considering that DevKitPro is based on GCC / unix tools, I'd guess it rather would work worse there than better. ;)

You also must not use the latest versions of the other libs -- it would be easier if devkit pro wouldn't make incompatible changes to their API every other release or so... Anyway, here are the lib versions I have installed:

libnds-1.3.1
libfat-nds-1.0.3

I think these three are all you need.

plover
Posts: 2
Joined: Thu Jul 02, 2009 9:34 am

Post by plover »

Thanks, I'll give that a shot... :D

Post Reply