Please test! ScummVM DS 0.13.1 beta2 download here!

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Please test! ScummVM DS 0.13.1 beta2 download here!

Post by agentq » Sat Apr 11, 2009 2:29 am

Please note, this build is obsolete.

For the current beta, try here:
viewtopic.php?t=7145



Please test this new beta version of ScummVM, and post your results here. If you try this out, please post how you got on here, whether it worked or not.

When you post, try to include:
* Your card reader
* The game you were testing (including which language it runs in)

If you see problems, please post the details of those too.

Since this is hopefully the final beta, if you use this build, please post a short message with what game you played, and what hardware you used. That way I know what has been tested.

Since this is a beta version, full instructions are not yet available, but instructions for use are essentially the same as the previous version, so see the ScummVM DS website at http://scummvm.drunkencoders.com

http://scummvm.drunkencoders.com/scummv ... 2beta2.zip


Fixes in beta2:
- Fixed a bug where the top screen would corrupt when the console
was turned off
- Fixed a possible crash on boot
- Fixed a memory leak in the load game dialog in SCUMM games.




New features:
- Access to the global ScummVM main menu. Hold select during the game to access it.


Supported Games


Build A:
Manic Mansion
Zak McKracken and the Alien Mindbenders
Indiana Jones and the Last Crusade
Loom
Passport to Adventure
The Secret of Monkey Island
Monkey Island 2: LeChuck's Revenge
Indiana Jones and the Fate of Atlantis
Day of the Tentacle
Sam & Max Hit the Road
Bear Stormin' (DOS version only)
Fatty Bear's Birthday Surprise (DOS version only)
Fatty Bear's Fun Pack (DOS version only)
Putt-Putt's Fun Pack (DOS version only)
Putt-Putt Goes to the Moon (DOS version only)
Putt-Putt Joins the Parade (DOS version only)

Build B:
Beneath a Steel Sky
Flight of the Amazon Queen

Build C:
Simon the Sorcerer 1/2
Elvira 1/2
Waxworks (Amiga version only)

Build D:
Sierra AGI games
Gobliiins 1 - 3
Bargon Attack
Ween: The Prophecy
Future Wars
Lost in Time

Build E:
Inherit the Earth (DOS Floppy version only)

Build F:
Kyrandia 1 - 3 (I'm not sure which ones will work, please test them!)

Build G:
Lure of the Temptress

Build H:
Nippon Safes
Last edited by agentq on Sat Apr 18, 2009 1:16 pm, edited 3 times in total.

Mortys
Posts: 33
Joined: Mon Oct 09, 2006 10:05 pm

Post by Mortys » Tue Apr 14, 2009 7:06 pm

Hi agentq
Just try Sam & Max (french) and everything seems ok except that (for me) the "low sound quality" sounds better than the "high quality" but maybe it's my ears or headsets.

tirges
Posts: 6
Joined: Tue Mar 24, 2009 10:06 pm

Post by tirges » Wed Apr 15, 2009 12:26 am

Hi,

Using M3Real (with GBA expansion) the return to main launcher (holding select) results in a crash.

If I recall correctly this DID work correctly in the FullThrottle/Dig [scummvmds0-13-1-ftdigtest2] version, but now it also crashes there (scummvmds0-13-1-ftdigtest5)

'Quit' (turning off the DS) only seems to work from the main launcher, not from within a game...


Oh and the 'H' version still has the 'G' icon ;-)

InnocentBystander
Posts: 19
Joined: Wed May 03, 2006 12:54 am

Post by InnocentBystander » Wed Apr 15, 2009 3:29 pm

Using a TTDS here, no RAM pack. The option to return to the main menu works in Build D, but locks up Build A.

Also found a weird crash on Beneath a Steel Sky (floppy). If I try to save a game, and I'm typing on the console, and then hit the virtual ENTER, the game locks up. But if I type the game name, then switch screens and press the "save" button onscreen, it works.

User avatar
Hansi
Posts: 30
Joined: Sun Nov 11, 2007 11:19 am

Post by Hansi » Wed Apr 15, 2009 11:06 pm

Is a build with the Tinsel engine possible for DS?

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Wed Apr 15, 2009 11:56 pm

@tigres, : Okay, I've found and fixed the crash returning to launcher/quitting, thanks!

@InnocentBystander: I can't make the game crash when saving in Beneath a Steel Sky. I've done it loads of times but it always works fine for me.

Did you crash it at a certain point in the game? Or did you change any of the default options? Did you do it several times?

@Mortys: Did you realise you need to turn your DS off then on to change the sound quality after you change the setting?

If you don't do that your change won't take effect!

@Hansi: Yes, I believe a Tunsel build should be possible, but I haven't worked on it yet!

InnocentBystander
Posts: 19
Joined: Wed May 03, 2006 12:54 am

Post by InnocentBystander » Thu Apr 16, 2009 9:59 pm

@agentq

All of the defaults were left alone with version B. I had it happen twice, both in rooms early on in the game. If I recall, one was on the ledge just to the right of where you begin, and the other was in the room below it, in the room with the droid and the elevator.

Like I said, it only locked up if I hit "enter" on the virtual keyboard. And, oddly, it still saved successfully, and rather locked up immediately afterwards when trying to return control to me. I'm thinking it may have gotten confused by having the virtual keyboard showing, or something.

But, the TTDS kinda sucks, so if you can't recreate it, I'll just assume it's my cart.

Post Reply