"Invalid savegame" using r4sdhc need help!!!

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

User avatar
Graxer
Posts: 384
Joined: Sat Sep 13, 2008 2:24 pm
Location: Scotland

Post by Graxer » Mon Aug 17, 2009 10:25 am

I am also having problems with this. Whenever I save my game then load it, it comes up as "Invalid Savegame" and won't load. I'm using version 0.13.1 beta1 build A. Like the others I have a R4SDHC. I have never had any homebrew problems before. (And I don't think I had this problem with other versions of ScummVM, although I cant garuntee this!)

MasterLeo
Posts: 17
Joined: Mon Feb 09, 2009 2:10 pm

Post by MasterLeo » Wed Aug 19, 2009 3:55 pm

I am also using an R4SDHC card but my kernal version is R4i 1.09b i dont know if im using the right version or not also my micro sd card is formatted to FAT32 if that matters.
But what my problem is is that i have the games on my sd card and whenever i go to the directory their in it says it doesnt contain any game files please help me im pretty much computer illiterate i have no idea what im doing.
Maybe you haven't noticed, but the scummvm package for the DS includes several nds executable files. In order to make a game work, you have to match the executable with a game that it supports.

You can find the list here:
http://scummvm.drunkencoders.com/#whichgames

So for example, the scummvm-a.nds file will be able to run games like Indy3/4, Monkey island 1/2, DOTT and so on. If you try to run these games with scummvm-b.nds, it won't work.
I am also having problems with this. Whenever I save my game then load it, it comes up as "Invalid Savegame" and won't load. I'm using version 0.13.1 beta1 build A. Like the others I have a R4SDHC. I have never had any homebrew problems before. (And I don't think I had this problem with other versions of ScummVM, although I cant garuntee this!)
I've found that the saved games only work if you give them a blank name (aka no name at all). If you give them a name a 0 bytes save file is created, which doesn't work. The problem is only with games that use scummvm's save interface, other games work fine, like FOTAQ. I really don't know if this is a scummvm bug, or the R4 DLDI bug, but it's been around at least since 0.11.

User avatar
Graxer
Posts: 384
Joined: Sat Sep 13, 2008 2:24 pm
Location: Scotland

Post by Graxer » Thu Aug 20, 2009 3:36 pm

MasterLeo wrote:I've found that the saved games only work if you give them a blank name (aka no name at all). If you give them a name a 0 bytes save file is created, which doesn't work. The problem is only with games that use scummvm's save interface, other games work fine, like FOTAQ. I really don't know if this is a scummvm bug, or the R4 DLDI bug, but it's been around at least since 0.11.
I have been naming mine for a few days and it seemed to be mysteriously working again. However today the save became invalid again. I thought it had been sorted in the new test build! :cry:

Post Reply