"Invalid savegame" using r4sdhc need help!!!

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

"Invalid savegame" using r4sdhc need help!!!

Post by Two_Beers » Tue Sep 23, 2008 7:09 am

Hi there!
Got a problem with my saving files, hope you can help me.
I`m using the r4sdhc card with the newest kernel version and newest version of scummvmds 0.11.1
The games work perfectly(day of tentacle,fate of atlantis,monkey island 1), but when i save a game and restart my nintendo ds, i cannot load my saved games.it says "invalid savegame". :twisted: i`m freakin out, cause i tried many things.No problem there with Fate of atlantis, but with the other both games.What can be my mistake?hope for answer.Thank you
P.S. excuse my bad, simple english

User avatar
Badablek
Posts: 60
Joined: Sun Jan 28, 2007 3:53 pm

Post by Badablek » Tue Sep 23, 2008 9:17 am

newest version of scummvmds 0.11.1
newest ??

the last one is version 0.12.0 beta4
viewtopic.php?t=6161

try with that version :wink:

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Post by tomten » Tue Sep 23, 2008 9:30 am

Badablek wrote:
? wrote: newest version of scummvmds 0.11.1
newest ??
the last one is version 0.12.0 beta4
viewtopic.php?t=6161
try with that version :wink:
Well, that's the latest unstable beta version. 0.11.1 is the version you should use if you want maximum stability.

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

Post by Two_Beers » Tue Sep 23, 2008 10:42 am

tried the other version....same problem!only fate of atlantis seems to save properly, monkey island and day of tentacle make invalid savegames.
perhaps the files in my game folders make the difference?

Atlantis: "Atlantis.000" and "Atlantis.001"

Day of Tentacle: "Monster.SOU" "Tentacle.000" "Tentacle.001"
"Tentacle.exe"

Monkey Island: "Monkey1.000" "Monkey1.001" "track1-track23"

got no idea what the problem could be

User avatar
MusicallyInspired
Posts: 991
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired » Tue Sep 23, 2008 1:08 pm

Just so you know, Tentacle.exe doesn't need to be in the game folder.

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

Post by Two_Beers » Wed Sep 24, 2008 8:58 am

all right, but doesn`t solve my problem.Nobody knows what to do?

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Post by tomten » Wed Sep 24, 2008 10:10 am

Two_Beers wrote:all right, but doesn`t solve my problem.Nobody knows what to do?
No idea. But others are using ScummVM on R4 with success. Some things you can try:

1. Make sure you've correctly DLDI patched the ScummVM .nds files using the correct DLDI

2. Make sure your R4 has the latest kernel

3. Test the same game files (DOTT & MI1) with the latest stable desktop ScummVM (i.e. Win/OSX/etc) and see if loading saved games works there.

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

Post by Two_Beers » Wed Sep 24, 2008 10:27 am

oh i thought that the new kernel and scummvmds 0.11.1 is already DLDI patched....
point 2 and 3 are positive, no probs there.
got the link for the actually DLDI patch?
can`t find it.
I have got a r4sdhc V1.21..Thank you so much!

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Post by tomten » Wed Sep 24, 2008 10:34 am

Two_Beers wrote: oh i thought that the new kernel and scummvmds 0.11.1 is already DLDI patched....
Yeah, most carts do auto-DLDI-patching these days. It was just something you should test.
2beers wrote: got the link for the actually DLDI patch?
can`t find it.
I have got a r4sdhc V1.21..Thank you so much!
Hmm... Is that the same as R4DS?

EDIT: OK, after some googling on GBATemp it seems R4sdhc is a cheap clone with bad support and bad reputation. It's possible ScummVM doesn't fully work on it. But I still think DLDI might be the issue. It should be this one:
http://dldi.drunkencoders.com/index.php?title=R4_DS
R4sdhc isn't mentioned explicitly, but try it anyway.

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

Post by Two_Beers » Wed Sep 24, 2008 11:28 am

so the r4sdhc works as the same as r4sd,
but i`m not able to patch it...i do not really understand how to patch correcly...i`ll google for it..thanks for your help...used dldi-no patch and yes-patch on the scummvm-a.nds file.with no-patch scumm doesn`t even start anymore and with yes-patch i got still the saving problem.and i don`t know how to use the dldi files....
well i will try

Two_Beers
Posts: 6
Joined: Tue Sep 23, 2008 7:02 am

Post by Two_Beers » Thu Sep 25, 2008 8:30 am

Okay i patched it, but same problem :cry:
damn!!!!

another world
Posts: 117
Joined: Sat Feb 23, 2008 4:05 am

Post by another world » Wed Oct 15, 2008 6:38 am

r4sdhc kits are clones of the r4 running a decrypted and hacked version of the final 1.18 loader before team r4 called it quits thanks to a law suit from nintendo.

what that means is the dldi autopatching or ability to allow card write access may be broken in the hacked firmware. the r4 autopatches dldi there is no need to have the dldi on the card or to patch before hand.

you really should head over to gbatemp.net and post in the r4 section but beware of flames. the r4 is outdated, dead, and gone... and people will remind you of that constantly.

-another world

Doomsdayman
Posts: 5
Joined: Sat Apr 11, 2009 7:32 am

Post by Doomsdayman » Sun Apr 12, 2009 7:47 am

I got a problem scumm says that it cant find the game in the directory i played the game on scumm on my pc and i installed scummvm corectly i have the newest R4 Kenel i think that the R4 isnt comateble because it use's slot 1 still weird why do you need too use the GBA port insted of the DS port its a ds any way hope that they will fix it fast i only can play 5 games

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Sun Apr 12, 2009 4:22 pm

If you're using an SDHC card bigger than 2Gb, you might want to try with one that's 2Gb or less. Another user reported problems with larger cards.

pbrmagnet
Posts: 3
Joined: Sat Aug 15, 2009 9:42 pm

I cant help you but perhaps you may be able to help me

Post by pbrmagnet » Sun Aug 16, 2009 1:44 am

I am also using an R4SDHC card but my kernal version is R4i 1.09b i dont know if im using the right version or not also my micro sd card is formatted to FAT32 if that matters.
But what my problem is is that i have the games on my sd card and whenever i go to the directory their in it says it doesnt contain any game files please help me im pretty much computer illiterate i have no idea what im doing.

Post Reply