DSTT Failed scummvm startup - Touch screen blank

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

kevlarrelic
Posts: 2
Joined: Wed Sep 10, 2008 5:42 am

DSTT Failed scummvm startup - Touch screen blank

Post by kevlarrelic » Wed Sep 10, 2008 6:12 am

Scummvm hangs on my DSTT before it can start up, leaving the bottom screen blank. What makes this strange is that I've used scummvm with no problems on this same DSTT before.

Just now I tried reinstalling scummvm to play Day of the Tentacle and discovered it would no longer work. Monkey Island and Sam and Max are the two that played fine before, however I've reformatted my card several times since then.

AFAIK scummvm should work on the DSTT without dldi patching, right? I am pretty sure I didn't have to patch it the first time I installed it, but I ain't positive. All of my other homebrew still works fine never having patched them.

All the powers of google and a search of these forums wasn't able to tell me what the problem is, so I was hoping you guys could help.

When I run the scummvm-a.nds file, the last thing that appears on the upper screen before freezing is something along the lines of "Zip file found!". I also tried running it through the scummvm-a.ds.gba file and came up with a much more interesting error:

DLDI Driver not patched!
DLDI initialize failed.
DLDI Driver not patched!
DLDI initialize failed.

No file system was found.
View readme file for more information.

Since the DSTT auto patches DLDI, and scummvm supports that kind of thing, I assume DLDI isn't really the problem?

So I was thinking that maybe it was a recent update of the DSTT firmware that is incompatable with scummvm, so is there another DSTT owner on here who can confirm if scummvm does or does not work with current firmware?

Sorry for being so long winded about the whole thing, I just got done with hours of trying to make it work and am still thinking out loud.

Thanks for your help!

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Re: DSTT Failed scummvm startup - Touch screen blank

Post by tomten » Wed Sep 10, 2008 6:32 am

kevlarrelic wrote:Since the DSTT auto patches DLDI, and scummvm supports that kind of thing, I assume DLDI isn't really the problem?
Depends on how the auto-patching is done. If it's transparent to ScummVM, it won't work. Try patching manually.

User avatar
iPwnzorz
Posts: 301
Joined: Sat Jan 06, 2007 3:55 pm
Location: Hampshire, England

Post by iPwnzorz » Wed Sep 10, 2008 6:33 am

Why don't you try patching..?

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Wed Sep 10, 2008 7:55 am

If you get the 'Zip file found!' message, remove the cartridge in your GBA slot and try again.

kevlarrelic
Posts: 2
Joined: Wed Sep 10, 2008 5:42 am

Post by kevlarrelic » Wed Sep 10, 2008 6:32 pm

agentq wrote:If you get the 'Zip file found!' message, remove the cartridge in your GBA slot and try again.
Oh thank you Jesus and hallelujah, that fixed it! I got the GBA ez flash expansion after I got scummvm to work the first time, so that would do it I guess.

So it doesn't like GBA cartriges, huh? Is it something to do with my specific hardware combination, or is it for all GBA stuff? Just out of curiosity, of course, now that my problem is solved thanks to agentq.

Time for me to foil the plans of an evil tentacle. Thanks again!

User avatar
Jimbob
Posts: 305
Joined: Mon Oct 31, 2005 4:36 pm
Location: Somewhere in the UK

Post by Jimbob » Sat Feb 21, 2009 11:11 am

Apologies for digging up this thread but I received a DSTT card this morning and the second thing I tried on it was ScummVM. I've downloaded the 0.13.0 beta zip file from the first post in the forum but all I get are black screens, the top screen displays: -

DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!

Now, I'm pretty new to using DS homebrew stuff but ZXDS worked first time.

Can anyone help? The only DLDI patcher available to me is DLDI Drop for OS X and that doesn't have the DSTT card listed. I'm not even sure if I'm able to ask for help with the DSTT card, I don't think it's on the supported cards list.

Thanks,

Jimbob

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Post by tomten » Sat Feb 21, 2009 11:18 am

Jimbob wrote:DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!
This looks right. Can you try an older version, like the latest 0.12.x version?

User avatar
Red_Breast
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast » Sat Feb 21, 2009 1:48 pm

A similar message comes up on my CycloDS Evo at the top then the classic (memory limitations) menu at the bottom.
So that's how it should be.
Strange.
The builds at the top are Ender's.
Agentq made some builds in a post further down. Maybe try them as well.
viewtopic.php?t=6161
Good luck.

User avatar
Jimbob
Posts: 305
Joined: Mon Oct 31, 2005 4:36 pm
Location: Somewhere in the UK

Post by Jimbob » Sat Feb 21, 2009 2:32 pm

Yeap, the 0.12.0 beta 4 builds appear to be working (well Indiana Jones and The Fate of Atlantis is working).

Thank you for your help!!

hyperhaggis
Posts: 1
Joined: Sun Mar 08, 2009 12:58 am

Post by hyperhaggis » Sun Mar 08, 2009 1:01 am

I have the same problem with my NDSTT in that it shows the top screen but nothing on the bottom for me to add my games. I've tried the 0.11 and 0.12 builds with no success. Can someone help me please?

Abby90
Posts: 1
Joined: Sat May 16, 2009 9:34 am

Post by Abby90 » Sat May 16, 2009 9:39 am

hyperhaggis wrote:I have the same problem with my NDSTT in that it shows the top screen but nothing on the bottom for me to add my games. I've tried the 0.11 and 0.12 builds with no success. Can someone help me please?

I get this
DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!

too.

I have also tried other versions. 12, 11 and the new one. But I see at the bottom of the screen nothing.

I use NDTT..

marzipan
Posts: 301
Joined: Fri Nov 25, 2005 4:10 pm

Post by marzipan » Sun May 17, 2009 12:19 am

I should point out that it's not really ScummVM DS disliking Slot-2 cartridges, but more about what kind of content is on them. I had this problem before many a moon ago (thread should still exist if you care to find it), and it seems if whatever content you have on your EZ-Flash is zip-compressed, ScummVM DS will notice that and assume you want to load games through the old 'GBA Flash Cart' method. So if you'd prefer to keep your cartridge inside when using the program, overwrite its NOR space with something else.


Simple really!

Ilpo
Posts: 1
Joined: Mon Mar 08, 2010 1:37 pm

Post by Ilpo » Mon Mar 08, 2010 1:50 pm

I have this same black screen problem. Top screen displays:
DLDI Device:
'DSTT DLDI(boyakkey ver.)'
DLDI Driver Initialised OK!

I have tried older versions didnt work. I use DSTT. Can anyone help?

tanij
Posts: 2
Joined: Thu Mar 18, 2010 7:25 am

Post by tanij » Thu Mar 18, 2010 7:30 am

I'm having a little trouble too sorry..

I'm getting:

DLDI Device
TTCARD IO Library
DLDI Driver Initialised OK

but nothing appears on the touchscreen. The weird part about it is that it worked for about a day with Day of the Tentacle and Monkey Island 2 but now doesn't seem to work at all.

I'm using an R4 and have tried versions 0.13.1 and 1.0.0.

Sorry to post this is an older thread..any help at all though would be awesome : )

User avatar
Red_Breast
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast » Thu Mar 18, 2010 1:07 pm

tanij wrote:
I'm using an R4 and have tried versions 0.13.1 and 1.0.0.
So you're not trying with the latest version.

Post Reply