problem with wav files

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
Stremon
Posts: 14
Joined: Fri Jul 27, 2007 8:48 am

problem with wav files

Post by Stremon » Fri Jul 27, 2007 9:25 am

Hi, I've a problem with the wav files ripped from the original CD of games. I've converted the cd files with cdex in this format :
Format: WAV
Compression: IMA ADPCM
Samplerate: 22050 Hz
Channels: Mono
On the fly encoding: On
When I start Monkey Island, Loom or gobliiins with wav tracks, the games crash at the beginning :cry: .
It's supposed to do this bug only with mp3 files, but for me the mp3 files work, very slowly, but it works.
I have the EZFlash-V with last updates and I've correctly patched the scummvm files (0.10.0b2) with DLDI.
Does someone have an idea to solve my problem ?

Sorry for my bad english I'm french :wink:

GriffNorris
Posts: 20
Joined: Mon Dec 04, 2006 6:58 pm

Post by GriffNorris » Mon Jul 30, 2007 8:21 am

If in doubt, read the manual/faq. I know it sounds stupid, and maybe some other guys here will be able to help, but I'm sure there was something like this in the FAQ. I'm not flaming you, and good luck on getting an answer (almost everyone here is really helpful when you have a problem), but I would say read the faq in the meantime.

Sorry this seems entirely redundant, and sorry if you've already read it to no avail.

Fairly good English though I think, it was just the jargon I didn't understand lol.

Il faudrait que je sais un petit peu de plus avant de répondre à une question. Désolée pour que je ne suis pas fort en Français et alors je viens de faire beaucoup des erreurs, mais j'espere que vous recevriez (?) un reponse utile. Ca va? Si vous voulez je pouvais essayer de traduire les mots anglais qui vous ne comprenez pas. Alors, bon chance, SCUMMVM est excellent et toute comme ça. Je ne sais pas ce que je dirais maintenant, alors je devrais dire au revoir!

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Mon Jul 30, 2007 9:09 am

When you convert the files with Cdex, make sure you choose the option to 'Extract CD tracks to a compressed audio file' and not 'Extract CD tracks to a WAV file'.

If in doubt, press Y when you start the game to show the debug console, and any error messages concerning WAV files will be displayed here.

Stremon
Posts: 14
Joined: Fri Jul 27, 2007 8:48 am

Post by Stremon » Tue Jul 31, 2007 9:38 am

I've cheked the wav format a lot of times and it's exactly the same than in the FAQ :?
Another person who have an EZFlash-V has tried to play games with wav files, and it does the same thing...
The problem is apparently the same with all EZ-V cards, but not with other linkers...
I've done a lot of tests, and I sought the source of this bug, and there is 3 possibilities :
- ScummVM ds does not work correctly with EZ-V due to wrong DLDI management.
- The EZ-V doesn't accept the access of the wav files in SD card
- The DLDI patcher for EZ-V does not do its work correctly with this homebrew (I think it's the most credible possibility)

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Thu Aug 02, 2007 12:55 pm

I think it's very unlikely that the EZ-V would run perfectly except for the WAV files. It's more likely that you've set something up incorrectly.

I have borrowed an EZ-V and will try the WAV audio at some point over the next few days to check that it does work on the card.

ccosmos
Posts: 3
Joined: Thu Aug 02, 2007 6:24 pm

Post by ccosmos » Thu Aug 02, 2007 6:39 pm

Hi agentq.
Just to tell that i have the same problem than Stremon with Gobliiins.
Tested with scummvm 0.9.1a and the last beta and got, on top screen the mouse icon and black screen on bottom when i launch the game. NDS keys does not works after that, the emulator is crashed, so i can't see the debug screen.

There is only one big music track on this game and i have converted it with cdex (WAV, IMA ADPCM, 22050Hz, mono, 4 bits, named track2.wav and copied into gobbliiins directory)
Is there something we must configure in audio tab (like music driver ?) before runnning the game ?

EZV + kernel 1.41 + ezshell v070328 + "none" save setting for homebrews + 1 GB SD-C01G JAPAN (FAT32)
Thanks.

Stremon
Posts: 14
Joined: Fri Jul 27, 2007 8:48 am

Post by Stremon » Fri Aug 03, 2007 6:30 pm

Hi agentq, did you try scummvm ds with EZ-V and wav tracks ?

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Sat Aug 04, 2007 9:29 am

Yes, I did try it, and it didn't work for me either.

I tracked the bug down to a CPU syncronisation issue, of all things. Keep a look out for the 0.10.0a release, which should be due very soon, and CD audio will work for you.

ccosmos
Posts: 3
Joined: Thu Aug 02, 2007 6:24 pm

Post by ccosmos » Sat Aug 04, 2007 10:17 am

Great news agentq.

Thanks a lot ;)

Stremon
Posts: 14
Joined: Fri Jul 27, 2007 8:48 am

Post by Stremon » Sat Aug 04, 2007 11:52 am

Thanks :D

Post Reply