Error while starting games on Nokia 6600

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

User avatar
iedutu
Posts: 23
Joined: Mon Oct 31, 2005 8:12 am

Error while starting games on Nokia 6600

Post by iedutu » Mon Oct 31, 2005 8:24 am

Hi!

When starting any of these 3 games (see below), I'm getting an error message:

App. closed
SDL_b
E32USER-CBase 66


After selecting OK, the game starts (no sound, though)

My phone: Nokia 6600
ScummVM Version: 0.8.0 release
scummvm.ini file:

[scummvm]
FM_high_quality=false
FM_medium_quality=false
joystick_num=0
lastselectedgame=loom
music_driver=auto
music_volume=192
native_mt32=false
sfx_volume=192
speech_volume=192
subtitles=true
versioninfo=0.8.0

[loom]
description=Loom (English (US)/DOS)
language=en
path=E:\Games\Loom\
platform=pc

[monkey]
description=Monkey Island 1 (English (US)/DOS)
language=en
music_volume=192
path=E:\Games\MI1\
platform=pc
sfx_volume=192
speech_mute=false
speech_volume=192
subtitles=true

[monkey2]
description=Monkey Island 2: LeChuck's revenge (English (US)/DOS)
language=en
path=E:\Games\MI2\
platform=pc





Thanks!
Cristian.[/b]

cyke64
Posts: 4
Joined: Mon Oct 31, 2005 3:49 pm

Post by cyke64 » Mon Oct 31, 2005 4:00 pm

Hello ,

I have the same problem as you :-( (MI 1 game)

"App closed SDL_b" error (I push OK)
Then "Program Closed SDL_b E32USER_CBase 66" error
After the game starts but with no sound !

Info : Nokia 6600 5.27.0 with ESCUMMVM second edition download

VooD
Posts: 4
Joined: Mon Oct 31, 2005 11:54 pm

Post by VooD » Mon Oct 31, 2005 11:59 pm

I also have the same problem with both versions.

"Aplicación cerrada SDL_b" (Closed application SDL_b)

My firmware version is:

V 5.27.0
28-06-04
NHL-10

Btw I formated my phone back to factury defaults a couple of days ago, and my LIBS folder on the mmc is pretty clear, so is not caused by an unclean phone.

Some games starts, but I get no sound at all.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

So what version of ScummVM are you running on your 6600

Post by Anotherguest » Tue Nov 01, 2005 6:08 am

V1 or V2?
The 6600 is a V2 device, and what changed most in terms of BC breaks between V1 and V2 is the sound apis. THe crash you are seeing is the sound thread falling over.

vq304
Posts: 9
Joined: Tue Nov 01, 2005 6:44 am
Location: Australia

Post by vq304 » Tue Nov 01, 2005 6:46 am

I guess it's happening to all us 6600 owners. Mine does it too - v4.09.1, EScummVM V2.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

I found one place in the code

Post by Anotherguest » Tue Nov 01, 2005 7:26 am

Which would crash the sound. But even without the crash, the sound will probably still be disabled.

VooD
Posts: 4
Joined: Mon Oct 31, 2005 11:54 pm

Post by VooD » Tue Nov 01, 2005 9:38 pm

I tryed sometime ago a"probe of concept" version made by someone and the sound was working pretty nice.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Nov 01, 2005 10:03 pm

Yes thats true, that used my NON-SDL sound backend together with a stereo->mono conversion written by Matan. Less overhead than the normal SDL implementation. But not a lot actually. So its strange. But I have found acouple of issues which can fix some of the panics at least.

Titus
Posts: 5
Joined: Thu Nov 03, 2005 9:27 am

Post by Titus » Thu Nov 03, 2005 2:42 pm

What have you found that can fix it? Where can i download the fix by Matan?
I have 7610...

I'm writing from Hungary! :)

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu Nov 03, 2005 3:57 pm

Well Matan released the 0.5.1 version of ScummVM. it is using a sample rate of 8khz and that seems to be working better than the 16khz I am trying to use, even though the sound quality is much worse. I will se if I can get a version using 8khz in an easy way with the rest of releases.

Titus
Posts: 5
Joined: Thu Nov 03, 2005 9:27 am

Post by Titus » Fri Nov 04, 2005 7:46 pm

When will be serviceable version for 7610?
I waiting for sequels...

Titus
Posts: 5
Joined: Thu Nov 03, 2005 9:27 am

Post by Titus » Sun Nov 06, 2005 5:31 pm

Please! I need the sound fix for Nokia 7610! I will play my old favorit games: DOTT, SAMNMAX, MONKEY1-2!!! Please Anotherguest!

vq304
Posts: 9
Joined: Tue Nov 01, 2005 6:44 am
Location: Australia

Post by vq304 » Tue Nov 08, 2005 1:14 pm

I just tried the newest version that Anotherguest released at http://anotherguest.b0.se/cvsbuilds/, and now my 6600 has full music and sound in Monkey Island 2 :wink: Not in Monkey Island 1 though.

But maybe it's time to upgrade my phone, music does seem to slow it down a huge amount.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Nov 08, 2005 2:28 pm

Good testing! :-) Well yes..OPL music is very CPU intensive indeed, so it runs much smoother on the newer phones.

Titus
Posts: 5
Joined: Thu Nov 03, 2005 9:27 am

Post by Titus » Tue Nov 08, 2005 2:45 pm

THANK YOU MASTER!!! :D
I play my favorite games:
Sam and Max, Day of the Tentacle, Monkey Island 1-2, Zak, Maniac Mansion, Loom!!!!
And i hear the music and sound effects!!! You are the king Anotherguest!!!!

Post Reply