ScummVM 0.9.1a beta3 released for testing

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

ScummVM 0.9.1a beta3 released for testing

Post by agentq » Sat Mar 10, 2007 11:16 pm

THERE ARE NO CHANGES TO FILE LOADING/SAVING IN THIS RELEASE. IF YOU CARD DOESN'T HAVE A FULLY WORKING DLDI, YOU WILL NOT BE ABLE TO USE SCUMMVM DS ON A SLOT-1 CARD. THERE IS NOTHING I CAN DO ABOUT THIS.

These beta releases are meant to be bugfix only, but I've slipped in a new zoom feature since so may people asked.

These are the new features in v0.9.1a beta3 of ScummVM DS:
* Added 100%, 200% and 'Fit' options while zooming (Hold L and press A/B)
* Allow CD audio tracks to start from track 1 or 2
* Fixed long filename support to allow Mac versions of Scumm games to run
* Fixed broken turning controls during fights in Indiana jones

Download here:
http://scummvm.drunkencoders.com/scummv ... -beta3.zip

Please let me know of any bugs. If there isn't anything significant, this version may become the stable release.

cobaalt
Posts: 2
Joined: Mon Jan 29, 2007 12:26 am

Post by cobaalt » Sun Mar 11, 2007 1:52 pm

Wonderful. Works like a charm, and the new scaling options are perfect. Amazing work agentq, as always.

Shtroodle
Posts: 12
Joined: Sat Feb 03, 2007 9:33 am
Location: Stankonia

Post by Shtroodle » Sun Mar 11, 2007 7:21 pm

I'm not really sure if I missed the fit and 100% zoom for the top screen in previous versions, but it's really great. I always hated that enlarged pixelated view on one of the screens ;) Great work agentq and thanks.
Works great on R4.

TeenTin
Posts: 3
Joined: Wed Jan 17, 2007 2:58 am

Post by TeenTin » Mon Mar 12, 2007 12:33 am

R4 --- Perfect !!

User avatar
MetroidPrime
Posts: 92
Joined: Mon Aug 28, 2006 8:15 pm
Location: Germany

Post by MetroidPrime » Mon Mar 12, 2007 10:08 am

As always working perfectly on R4. The new zooming function is a great addition.

ascummyguy
Posts: 20
Joined: Sun Feb 26, 2006 3:03 am

Post by ascummyguy » Mon Mar 12, 2007 6:01 pm

I don't know if I'm the only one that has experienced this, but I'll post it just in case.

When I try using subtitles during talkie games they lag way behind the speech even if I set the subtitle speed to max.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Sat Mar 17, 2007 5:40 pm

Yeah, I noticed that too. Since it's not too serious (and it's been there for years), I will fix this for the next release rather than this one.

ascummyguy
Posts: 20
Joined: Sun Feb 26, 2006 3:03 am

Post by ascummyguy » Mon Mar 19, 2007 12:49 pm

Alrighty, thanks for the reply.

jewelie
Posts: 1
Joined: Tue Mar 20, 2007 12:21 pm

Post by jewelie » Tue Mar 20, 2007 12:33 pm

Hiya, there seems to be a mild short vs long filename bug, which I dare say may cause some confused bug reports?

Some older versions of ScummVMDS used to create .ini files with file and path names in truncated/DOS style (i.e. "MONKEY~2" rather than "Monkey Island 2"). 0.9.1a beta3 appears to be incompatible with .ini files containing paths ending in short filenames, and seems to require the last argument in the path to be a full long name. beta3 boots, and displays menus etc, and *seems* to otherwise look like it's happy, however, when you attempt to start a game, it just turns the DS off! Ooops.

Works a treat, of course, once the .ini's are updated to the long-names. :D

Ta-ra,
Julie

(Config: SuperCard CF, v1.7 firmware, ScummVM 0.9.1a beta3 patched with SCCF DLDI.)

PS Keep up the good work -- it's FANTASTIC being able to play the classic point&click's again on a handheld. THANK-YOU.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Sat Mar 24, 2007 9:06 am

Thanks for the info, I may add to the readme that you need to remove the game and re-add it in the ScummVM GUI.

evad_lhorg
Posts: 4
Joined: Mon Mar 26, 2007 2:40 pm

Post by evad_lhorg » Mon Mar 26, 2007 2:42 pm

Monkey Island 1 keeps freezing at the Lucasarts logo at the start for me

User avatar
Badablek
Posts: 60
Joined: Sun Jan 28, 2007 3:53 pm

Post by Badablek » Mon Mar 26, 2007 3:26 pm

evad_lhorg wrote:Monkey Island 1 keeps freezing at the Lucasarts logo at the start for me
Do NOT use Mp3 files with MI1...you need to recompress audio tracks in WAV ADPCM format, 22kHz, 4 bit, mono..

evad_lhorg
Posts: 4
Joined: Mon Mar 26, 2007 2:40 pm

Post by evad_lhorg » Mon Mar 26, 2007 4:19 pm

excuse the stupidness but how do I do that?

User avatar
Badablek
Posts: 60
Joined: Sun Jan 28, 2007 3:53 pm

Post by Badablek » Mon Mar 26, 2007 5:32 pm

You can use Winamp and follow this :

launch Winamp

Options > Preferences > Plugins > Output

Choose "Nullsoft Disk Writer"

Click "Configure"

Check "Convert to format"

Click "..."

Format : IMA ADPCM
Attributs : 22,050 kHz, 4 bit mono (10Kb/s)

Close Winamp options, and open all the CDDA (or MP3) tracks in winamp....instead of playing the tracks, it will convert them and put them in C:\ (if you didn't change the ouput folder)

When everything's done, do not forget to change the output plugin in Winamp (WavOut Output)

Now copy the files in MI1 folder (files must be named track01.wav, track02.wav, etc...) and have fun ;)

ps : of course, any audio edition software can do that, but Winamp is free and used by a lot of people, so I think it's the best choice ^_^

Check my answer here too : viewtopic.php?p=19828#19828

If you want to use Goldwave

evad_lhorg
Posts: 4
Joined: Mon Mar 26, 2007 2:40 pm

Post by evad_lhorg » Mon Mar 26, 2007 7:26 pm

did all that and they are wave sound files now and I put them in the folder replacing the mp3 files and still no music.... and I assume there should be music when the "secret of monkey Island" logo comes up and when you are in the scumm bar



there is sound when I open doors but thats it

Post Reply