ScummVM under Win95 OSR2 ?

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
redgoblin
Posts: 3
Joined: Tue Nov 15, 2005 9:23 am
Location: UK

ScummVM under Win95 OSR2 ?

Post by redgoblin » Tue Nov 15, 2005 11:27 am

:D Hi (and calling all experts),

I've been happily using ScummVM 0.7.1 (and VDMSound FTR) under Win2k for some time but, with some excellent games (e.g. Callahan's Crosstime Saloon) unplayable or (e.g. The Feeble Files) impossible to run (even with compatibility fixes), the time has come to set up a dedicated (Win95 OSR2) legacy gaming PC (spec. on request as hopefully irrelevant). OK so far but two remaining issues are insufficient conventional RAM for half a dozen games (needing DOS Mode tweaks) and ScummVM ...

Now, according to the FAQ, ScummVM has been tested under Win95 but I assume not lately because, though 0.7.1 installs without error, it crashes (complaining about a missing user32.dll GetAncestor export) as soon as run. Now, according to M$ (ref. 1), GetAncestor first appeared in Win98/NT4SP4; which begs a few questions:
:?: Am I missing something? :oops:
:?: Can Win95 use a Win98 user32.dll?
:?: If so, where might I source one?
:?: Or must I downgrade ScummVM?
:?: If so, to which version? :arrow:

:arrow: I'd rather not lose play compatibility (saved game compatability far less important) with the following PC games:
* Beneath a Steel Sky (CD)
* Day of the Tentacle (CD)
* Flight of the Amazon Queen (talkie)
* Indiana Jones and the Fate of Atlantis (CD)
* Indiana Jones and the Last Crusade
* Loom (CD)
* Maniac Mansion (original)
* Sam & Max Hit the Road (CD)
* Simon the Sorcerer 1 (talkie)
* Simon the Sorcerer 2 (talkie)

Cheers,
RG

Ref. 1: http://msdn.microsoft.com/library/defau ... cestor.asp

Kirben
ScummVM Developer
Posts: 416
Joined: Wed Sep 21, 2005 12:15 pm
Location: Melbourne, Victoria, Australia

Post by Kirben » Tue Nov 15, 2005 12:43 pm

The problem was due to an earlier version of SDL that broke Windows 95 support, which was included with ScummVM 0.7.1.

Update to ScummVM 0.8.0 to solve the problem.

Or if you must stick with ScummVM 0.7.1, download the updated SDL runtime from http://www.libsdl.org/release/SDL-1.2.9-win32.zip and extract to the ScummVM directory.

User avatar
redgoblin
Posts: 3
Joined: Tue Nov 15, 2005 9:23 am
Location: UK

Post by redgoblin » Wed Nov 16, 2005 9:18 am

:oops: Thanks for the swift response Kirben,

Yes, 0.8.0 indeed works a treat as you say (and your explanation for 0.7.1 was most welcome, not to say revealing).

I suppose I really ought have tried the latest version up front but took a conscious decision not to do so on the assumption (always a dangerous thing, I know) the incompatability arose from a design necessity and was therefore likely to have been carried forward. But (maybe finally learning from one too many illogical adventure games) I decided to give it a whirl, ahead of seeing your reply, last night (UK time) and discovered it OK - by & large (but, hey, I'm in NO position to get picky).

Hmm, I wonder why I wasn't notified of your reply (time to check my profile, methinks) ...

Cheers & thanks again,
RG

Post Reply