FluidSynth missing and starting issues on latest builds

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Post Reply
shinbaka
Posts: 3
Joined: Tue Jun 16, 2020 2:11 pm

FluidSynth missing and starting issues on latest builds

Post by shinbaka »

Hello everyone,

I'm a bit stuck right now and have a few issues with the latest builds of ScummVM. But first things first, I'm on Android 10 (security patch 01. March 2020) using the Samsung Galaxy Tab S6.

I can't get any stable builds working on the tablet. It doesn't matter if it is from the development builds, or the "regular" 2.1.1 build - and also the version doesn't matter (the arm64-version should be the right one, but I tried every version avaliable, just to be sure.)

When I start ScummVM, I get the following message:

https://drive.google.com/file/d/1Mr_BpJ ... p=drivesdk

Obviously, the app needs storage-access-permission, nothing strange about that. But the error-message is a bit weird.

https://drive.google.com/file/d/1MnspX3 ... p=drivesdk

But even after granting access, the app just closes and I can't start it again! There is just a black screen popping up for a second and then it closes again.

I DID however get it to work, when installing the Playstore-version first and update it to 2.1.1, but there are a few issues with this build. Nothing major, but stuff like the stretch-modes not working like they should,.

I can, however, also get the latest version from the dev builds to work, where the scaling for example works perfectly, but the FluidSynth-emulation seems to be missing in these builds - and I really like this feature.
Unfortunately, I can't update the "official"-version to any of these dev-builds to see, if that would change anything.

Has anyone had similar issues or knows, what might be going on? Or should I simply settle for either FluidSynth or nice scaling? Or is there something else I could try? Any help would be highly appreciated!

[Edit] I just noticed, the cloud-save feature is also missing from the latest dev-build, why is that?

User avatar
criezy
ScummVM Developer
Posts: 741
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: FluidSynth missing and starting issues on latest builds

Post by criezy »

The daily builds were switched to a newer Android NDK a few months ago, but not all dependencies have been recompiled with this new NDK yet. So indeed some features are disabled in this build. This is a known issue and is being worked on. But as we have no dedicated Android port maintainer, and developers working on this have little rée time, we cannot say when this will be fixed.

shinbaka
Posts: 3
Joined: Tue Jun 16, 2020 2:11 pm

Re: FluidSynth missing and starting issues on latest builds

Post by shinbaka »

criezy wrote:
Tue Jun 16, 2020 9:06 pm
The daily builds were switched to a newer Android NDK a few months ago, but not all dependencies have been recompiled with this new NDK yet. So indeed some features are disabled in this build. This is a known issue and is being worked on. But as we have no dedicated Android port maintainer, and developers working on this have little rée time, we cannot say when this will be fixed.
Thank you for the info, I thought I was going a bit crazy. And I hope I didn't sound like I was complaining! The work you people are doing here is absolutely amazing! I just wasn't sure if I was messing something up on my side. :)

Just curious, since I'm somewhat new to all that dev-build stuff, but is there some kind of overview what features are included/missing? I tried looking around the different buildbot-lists and github-infos, but most of it went waaaay over my head...

User avatar
criezy
ScummVM Developer
Posts: 741
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: FluidSynth missing and starting issues on latest builds

Post by criezy »

In ScummVM itself the About dialog has a list of the features that are included.

On buildbot this can also be seen in the output of the configure step for a daily build.
The daily builds are those with "??" instead of a commit range on https://buildbot.scummvm.org/builders/m ... roid_arm64. Clicking on the build number for one of those (build #3279 is the one for last night for example) will bring a summary of this build. In the "Steps and Logfiles" section you can click on the "stdio" link for the configure step (for example here is the one for last night). In this log you will see a number of lines such as "Checking for FluidSynth... no". And you will notice it is currently missing a fair number of features.

shinbaka
Posts: 3
Joined: Tue Jun 16, 2020 2:11 pm

Re: FluidSynth missing and starting issues on latest builds

Post by shinbaka »

Again, thank you for all your help!
criezy wrote:
Tue Jun 16, 2020 10:18 pm
In ScummVM itself the About dialog has a list of the features that are included.
Whoa... I just checked the "about"-dialogue and compared the compiled features in version 2.1.1 with the ones in the latest daily build. There really are a lot of features missing! :shock:
On buildbot this can also be seen in the output of the configure step for a daily build.
The daily builds are those with "??" instead of a commit range on https://buildbot.scummvm.org/builders/m ... roid_arm64. Clicking on the build number for one of those (build #3279 is the one for last night for example) will bring a summary of this build. In the "Steps and Logfiles" section you can click on the "stdio" link for the configure step (for example here is the one for last night). In this log you will see a number of lines such as "Checking for FluidSynth... no". And you will notice it is currently missing a fair number of features.
Ah, that's exactly what I was looking for! :D Thanks, dumb little me would have probably never found the right logfiles for the correct build. I keep checking them before asking more stupid questions!

Post Reply