Mt32 (MUNT) Midi Not working anymore after win 10 updates

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Hoover1979
Posts: 1
Joined: Sun Mar 31, 2019 9:51 am

Mt32 (MUNT) Midi Not working anymore after win 10 updates

Post by Hoover1979 »

On my Laptop (Acer Predator Helios 300) I had ScummVM installed using MUNT as the Mt32 Emulator due to ScummVM's internal MT32 Emulator being very crackly, and it was working fine when I played Space Quest 1 remake and Kings Quest 5 over Xmas.

My main rig is in the shop so I fired up the laptop to play my games on ScummVM and no midi music plays anymore. Only sound effects. The only change was some forced Windows 10 updates that had to go through when I turned the laptop on today (first time using the laptop since Xmas). I even tried reinstalling munt and no dice. I ran from ScummVM itself instead of the batch files I have shortcuts of. No dice.

I can get midi to work if I use ScummVM's own MT32 emulator but on the laptop, the sound is crackly and sounds terrible. The inbuilt Mt32 emulator is fine on my main rig. The laptop is the model with the i7-8750H and 6Gb GTX1060M, not the 7th gen i7 version. Could today's forced OS updates have caused this? if not I don't know what else could.

I used the laptop when I was away for Xmas and it was fine. before today I haven't used the laptop since Xmas and all of a sudden I can't get any midi to play on ScummVM with MUNT and the internal MT32 Emulator hates this laptop's Realtek audio device (I use a Sound Blaster Zx on my main rig and ScummVM's internal MT32 emulator works perfectly).

Post Reply