Blade Runner slower on ScummVM than original game (win7)

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Souledge
Posts: 2
Joined: Fri Nov 08, 2019 2:50 pm

Blade Runner slower on ScummVM than original game (win7)

Post by Souledge » Fri Nov 08, 2019 5:24 pm

Hey people, I wanted to play this classic with subtitles, so I figured playing it with ScummVM.

I noticed though that the game runs somewhat slower than the original game, especially the walking and running segments. I've watched a couple of youtube videos of people playing the game on ScummVM, and half of the videos show people with perfect speed, and the other half seem to have the same minor slowdown I have.
My cpu is running under 25%, so i don't think it's a hardware issue, and I've fiddled around with almost all the graphical settings, but nothing seems to change it.

Doe anyone know what could be causing this?
I play it on win7 x64 I5 2500 gtx 1060 16gb ram, if any of that should be relevant.

Praetorian
ScummVM Developer
Posts: 107
Joined: Tue May 08, 2007 8:54 am

Re: Blade Runner slower on ScummVM than original game (win7)

Post by Praetorian » Fri Nov 08, 2019 6:08 pm

Souledge wrote:
Fri Nov 08, 2019 5:24 pm
I noticed though that the game runs somewhat slower than the original game, especially the walking and running segments. I've watched a couple of youtube videos of people playing the game on ScummVM, and half of the videos show people with perfect speed, and the other half seem to have the same minor slowdown I have.
My cpu is running under 25%, so i don't think it's a hardware issue, and I've fiddled around with almost all the graphical settings, but nothing seems to change it.
Can you use a FPS counter app like FRAPs or the Nvidia one and report back the values and whether you get stable FPS rate?

Souledge
Posts: 2
Joined: Fri Nov 08, 2019 2:50 pm

Re: Blade Runner slower on ScummVM than original game (win7)

Post by Souledge » Fri Nov 08, 2019 6:18 pm

Sure, When I run the game in ScummVM it gives me a solid 58-60 in Fraps, it gives a solid 71 running it normally, seems kinda odd I think.

Praetorian
ScummVM Developer
Posts: 107
Joined: Tue May 08, 2007 8:54 am

Re: Blade Runner slower on ScummVM than original game (win7)

Post by Praetorian » Fri Nov 08, 2019 11:49 pm

Souledge wrote:
Fri Nov 08, 2019 6:18 pm
Sure, When I run the game in ScummVM it gives me a solid 58-60 in Fraps, it gives a solid 71 running it normally, seems kinda odd I think.
58-60 is expected for ScummVM since we implemented a frame limiter (...), set to 60 fps since there was little point for more fps for this game (most animations are of way lower fps, McCoy's is the only one with the higher fps number).

If you can build ScummVM from the source code, you can set your own value for the frame limiter (in engines\bladerunner\framelimiter.h) to check if it provides a smoother experience. You could also try the "High performance mode" checkbox in the "Engine" tab for Blade Runner in conjunction with changing the fps limit to see if it makes any difference. The "high performance mode" will be more CPU hungry.

I did intend at some point to have a dropdown under the Engine tab to at least allow choosing from a number of predefined settings between 60 and 120, but this type of control is not yet supported by the main GUI for the extra options in particular. It could be something to implement in the future.

Post Reply