Colonel's Bequest Amiga

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Krath16
Posts: 1
Joined: Wed Jun 20, 2018 4:23 pm

Colonel's Bequest Amiga

Post by Krath16 » Wed Jun 20, 2018 4:56 pm

Hello!

I decided to play my Amiga Version of Colone's Bequest on ScummVM. I know that some of the SCI Sierra games supported MT-32 on the Amiga like Space Quest 3. That one works great. I try MT32 with my Amiga version of Hero's Quest(Quest for Glory 1) on ScummVM and it crashes like I think it would. Now I try it on Colonel's Bequest and it loads the game. I even the display on the screen Welcome to the 20's like it would normally display on the MT32 but I get no music. The digital sounds work just fine. I have never seen that The Colonel's Bequest on Amiga supports MT32 but wonder if it was almost implemented at some point during development and then never completed. ScummVM displays "The Requested SCI0 sound has no MIDI note data for the currently selected sound driver. Would be really interested to know if it would be possible for the Amiga version of this game to work with the MT32 and get the superior digital sounds compared to the PC as well.

User avatar
Raziel
ScummVM Porter
Posts: 1005
Joined: Tue Oct 25, 2005 8:27 am
Location: A haunted Castle somewhere in the Bavarian Mountains
Contact:

Post by Raziel » Sat Jun 23, 2018 12:04 pm

That seems to be a general regression concerning the whole of Laura Bow (1).

I just tested with my DOS version and it's as silent, no MIDI playback in the whole intro (apart from the thunder, but i think that's a single digital sound).

Can you submit a bug report for it?

I also get this warning on the console
WARNING: Game has no native support for General MIDI, applying auto-mapping!
WARNING: MIDI parser: the requested SCI0 sound has no MIDI note data for the currently selected sound driver!

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun Jun 24, 2018 2:22 am

I have just tested with v2.0.0 and the latest master development version on Linux. The music in the Laura Bow 1 intro works fine with both Adlib Emulator and MT32 output on my version. This is the DOS version from 5.25 floppies.

Not sure why your version seems to be selecting General MIDI as I don't think the game supports that. At least the datafiles seem to include ADL.DRV, MT32.DRV etc. and thus suggest MT-32 MIDI is intended.

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Sun Jun 24, 2018 4:15 am

digitall wrote:I have just tested with v2.0.0 and the latest master development version on Linux. The music in the Laura Bow 1 intro works fine with both Adlib Emulator and MT32 output on my version. This is the DOS version from 5.25 floppies.
Same here on macOS

User avatar
Raziel
ScummVM Porter
Posts: 1005
Joined: Tue Oct 25, 2005 8:27 am
Location: A haunted Castle somewhere in the Bavarian Mountains
Contact:

Post by Raziel » Sun Jun 24, 2018 2:35 pm

This is the same bug that bites me with the Sherlock game:
bug #10309

@Krath16

Try setting "default" in the Options/Audio tab

That way you'll get music at least, but not with your hardware.

It seems with "default" it will cycle through the possible outputs and chose the first that will work. (or so i guess)

Post Reply