Where can we get a broken sword 2.5 that scummvm will accept

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Where can we get a broken sword 2.5 that scummvm will accept

Post by Serious Callers Only » Sun Jan 21, 2018 5:22 pm

The one on the official site doesn't seem to work:

Code: Select all

find . -depth -type f -print -exec sh -c ' head -c 5000 {} | md5sum ' {} \;
./license.txt
69c4986e066aafef6a871d70057be63f  -
./lang_fr.b25c
690caf157387e06d2c3d1ca53c43f428  -
./dbghelp.dll
2ea9288ed57f64dcf8ec8399a90702b9  -
./lang_en.b25c
7afa83d83255be75da12f7e81a4f4768  -
./lang_es.b25c
384c19072d83725f351bb9ecb4d3f02b  -
./unins000.dat
e621ea18281077b56540a5f75cdb7fd0  -
./patch000.b25c
b8a52ff52fe2dc304648ae874dd35605  -
./bsengine.exe
9e5fb1324b5606f63a72f733c69ccf10  -
./lang_pl.b25c
49dc1a20f95391a808e475c49be2bac0  -
./lang_hr.b25c
e881054d1f8ec1e527422fc521c25405  -
./lang_it.b25c
f3325666da0515cc2b42062e953c0889  -
./fmodex.dll
59468854662fe3c0aaadcbea21730115  -
./packages.lua
9ab182967dc66568ee7be7e8351fb285  -
./lang_pt.b25c
1df701432f9e13dcefe1adeb890b9c69  -
./changes.txt
007983942ac7a4cebc5f44af41d5f8db  -
./data.b25c
f8b6e03ada2d2f6cf27fbc11ad1572e9  -
./unins000.exe
a6ef454c20a091f9099f1dfb66422217  -
./lang_ru.b25c
deb33dd2f90a71ff60181918a8ce5063  -

Code: Select all

 find . -depth -type f  -exec sh -c ' du -b {} ' {} \;
6491	./license.txt
1006043	./lang_fr.b25c
1038848	./dbghelp.dll
170856736	./lang_en.b25c
987965	./lang_es.b25c
2887	./unins000.dat
204672	./patch000.b25c
1266176	./bsengine.exe
1281799	./lang_pl.b25c
1273217	./lang_hr.b25c
996197	./lang_it.b25c
354304	./fmodex.dll
452	./packages.lua
993812	./lang_pt.b25c
674	./changes.txt
654310588	./data.b25c
695642	./unins000.exe
1235378	./lang_ru.b25c

Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Post by Serious Callers Only » Sun Jan 21, 2018 6:04 pm

Ugh, never mind, it's just ubuntu being dumb again. The version of scummvm 2.0 dated december 17 that i downloaded from this very site says (with scummvm -z) that it doesn't support blade runner, last express, lost eden or broken sword2.5, which happen to be most of the games i was excited about in the last release.

Annoying.

User avatar
sev
ScummVM Lead
Posts: 1967
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev » Mon Jan 22, 2018 7:55 am

That is interesting. Broken Sword 2.5 was enabled on Dec 4, 2015, and on Feb 28, 2016, it was promoted to a fully working state.

How did it happen that it was not enabled in the release build? Could you please point to the exact download URL?


Eugene

Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Post by Serious Callers Only » Mon Jan 22, 2018 10:02 am

currently it is:

Code: Select all

dpkg -s scummvmPackage: scummvm
Status: install ok installed
Priority: optional
Section: games
Installed-Size: 35539
Maintainer&#58; Aleksey Samoilov <samoilov.lex@gmail.com>
Architecture&#58; amd64
Version&#58; 2.0.0-1~retrogames
Replaces&#58; scummvm-data &#40;<< 1.5.0-1&#41;
Depends&#58; libasound2 &#40;>= 1.0.16&#41;, libc6 &#40;>= 2.14&#41;, libfaad2 &#40;>= 2.7&#41;, libflac8 &#40;>= 1.3.0&#41;, libfluidsynth1, libjpeg8 &#40;>= 8c&#41;, libmad0 &#40;>= 0.15.1b-3&#41;, libmpeg2-4 &#40;>= 0.5.1&#41;, libogg0 &#40;>= 1.0rc3&#41;, libsdl2-2.0-0 &#40;>= 2.0.4&#41;, libsndio6.1 &#40;>= 1.1.0&#41;, libstdc++6 &#40;>= 4.1.1&#41;, libtheora0 &#40;>= 1.0&#41;, libvorbis0a &#40;>= 1.1.2&#41;, libvorbisfile3 &#40;>= 1.1.2&#41;, zlib1g &#40;>= 1&#58;1.1.4&#41;, scummvm-data &#40;= 2.0.0-1~retrogames&#41;
Suggests&#58; fluidsynth | timidity, beneath-a-steel-sky, drascula, flight-of-the-amazon-queen, lure-of-the-temptress
Breaks&#58; scummvm-data &#40;<< 1.5.0-1&#41;
Description&#58; engine for several graphical adventure games
 ScummVM is a `virtual machine' for several classic graphical
 point-and-click adventure games.  It is designed to run Adventure Soft's
 Simon the Sorcerer 1 and 2, Revolution's Beneath A Steel Sky, and games
 based on LucasArts' SCUMM &#40;Script Creation Utility for Maniac Mansion&#41;
 system.  SCUMM is used for many games, including Monkey Island,
 Day of the Tentacle, Sam and Max and more.  See the official compatibility
 list at <http&#58;//www.scummvm.org/compatibility.php> for a full list
 of supported games.
 .
 The game data of four games compatible with ScummVM is included in Debian.
 These are&#58;
 .
  - Beneath a Steel Sky                 &#40;package&#58; beneath-a-steel-sky&#41;
  - Drascula&#58; The Vampire Strikes Back  &#40;package&#58; drascula&#41;
  - Flight of the Amazon Queen          &#40;package&#58; flight-of-the-amazon-queen&#41;
  - Lure of the Temptress               &#40;package&#58; lure-of-the-temptress&#41;
 .
 To actually make use of ScummVM, you'll have to install one of these, or
 obtain the proprietary game data for another supported game from somewhere
 else.
Homepage&#58; http&#58;//www.scummvm.org

but i think i messed around meanwhile. I'll try to ppa-purge and reinstall from the site (i have ubuntu and i know i can't use the snapshots), and retry the games.

BTW, zvision is not enabled either. Retroarch scummvm core has most engines enabled (but not lost eden - or maybe it's just my files unrecognized).

BTW, it would be really nice if even if a engine was disabled, files could be recognized when asked but say 'but the engine was disabled during build'.

Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Post by Serious Callers Only » Mon Jan 22, 2018 10:20 am

Ok, i hadn't the ppa installed anymore and ppa purge told me i 'hadn't any packages installed with it', which was obviously wrong so i ended up using a script to tell me if had gotten rid of everything (still dunno), purged scummvm and reinstalled from the site.

The date is different (dec 26 vs dec 17).

zvision and broken sword 2.5 games add fine.

lost eden, blade runner and last express don't.

Sorry for the false alarm, i guess i got too excited with pre-release buzz, installed a snapshot from a ppa and forgot i hadn't actually got the release.

Though it's disappointing about lost eden being unrecognized. I didn't see the engine on the list either (there should really be a way to scroll that faster manually with a mouse scroll wheel).
edit: it's cryo, not a new engine doh.
Last edited by Serious Callers Only on Mon Jan 22, 2018 10:32 am, edited 2 times in total.

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon Jan 22, 2018 10:26 am

Serious Callers Only wrote:lost eden, blade runner and last express don't.
Those three games are not yet supported and we are still working on them. Lost Eden should be fully playable though, maybe with some small issues. There is still a lot of work to do for the other two before they can be supported.

Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Post by Serious Callers Only » Mon Jan 22, 2018 10:29 am

So lost eden *is* enabled on engines?
I assume this is the problem?

Code: Select all

md5sum EDEN.DAT 
ff6fe24ad8ce815f288664c357f15f2e  EDEN.DAT
$ head -c 5000  EDEN.DAT | md5sum
020b3ad90320721e682445814b2581d3  -
$ du -b EDEN.DAT 
449853776	EDEN.DAT


User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon Jan 22, 2018 11:56 am

Lost Eden should not yet be enabled in release builds as it is not yet supported. But it should be enabled in daily builds.

Serious Callers Only
Got a warning
Posts: 165
Joined: Thu Feb 25, 2010 7:44 am

Post by Serious Callers Only » Mon Jan 22, 2018 12:08 pm

Ok, that's fine. Ubuntu hasn't got a daily build, so i hope you can do a update to stable soonish.

Post Reply