Strange Music Bug in LSL3

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
CaptainJei
Posts: 196
Joined: Wed Jun 15, 2011 3:57 am

Strange Music Bug in LSL3

Post by CaptainJei » Tue Dec 19, 2017 4:35 am

I want to create a bug ticket for this, but I'm having trouble describing it. Basically, when playing Leisure Suit Larry 3, sometimes the ambient music just stops, but then it continues when I start typing something and the input box opens, but then stops again after pressing enter.

It happens frequently, but it's difficult to predict WHEN it will happen. Also, it doesn't persist when restoring a game that was saved while the music glitch was occurring.

User avatar
snover
ScummVM Developer
Posts: 20
Joined: Sun Dec 17, 2017 6:45 pm

Post by snover » Tue Dec 19, 2017 4:58 am

The MIDI code in SCI engine is very broken right now, so crazy glitches like this are unfortunately pretty common. My understanding is that this can be especially the case for SCI0 games like LSL3, since SCI0’s MIDI system ran in a fundamentally different way than SCI1+, and this old design was never accurately implemented in ScummVM.

One of my next projects is to work on fixing all of this. It will take a while because there are a lot of different MIDI variants. If you can’t create a reproducible test case, don’t worry too much about it, since the rewrite of this code should hopefully just take care of it.

User avatar
CaptainJei
Posts: 196
Joined: Wed Jun 15, 2011 3:57 am

Post by CaptainJei » Tue Dec 19, 2017 5:15 am

Sounds good. Thanks for the explanation, and thanks for all the SCI engine improvements you and the others have been working on.

Post Reply