[SOLVED]Return to Zork: Error when running from command line

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Posts: 2
Joined: Mon Sep 04, 2017 4:33 pm

[SOLVED]Return to Zork: Error when running from command line

Post by SixOfTwelve » Fri Sep 08, 2017 7:34 pm

Hi everyone, long time user, first time poster here...

I've encountered the following problem on both my Windows 7 (32bit) machine and my Windows 10 computer:

When I try to run Return to Zork via command line, the screen goes black for a few seconds, then a window pops up with this message:

Code: Select all

Assertion failed!

Program: e:\emulators\scummvm\scummvm.exe
File: engines/made/made.cpp, Line 77

Expression: _gameid !=-1

Abort / Retry / Ignore
When I click on "Ignore", the game runs anyway.
When using the current 1.9.0 version, it does so without comment, when using the daily build, I get this additional message in a DOS window:

Code: Select all

Failed to query the CD TOC: 21
My scummvm.exe is in e:\emulators\scummvm\
The Return to Zork data files are in f:\roms\scummvm\rtz

This is the command line I use:

Code: Select all

e:\emulators\scummvm\scummvm --path=f:\roms\scummvm\rtz -f rtz
Similar use of the line with other scummvm titles works fine, for example

Code: Select all

e:\emulators\scummvm\scummvm --path=f:\roms\scummvm\lucas\fulltrtl -n -f ft
runs Full Throttle without complaint.

I've tried both my original CD version of Return to Zork as well as several other sources, including the floppy version. All of these work just fine when running them from inside the ScummVM GUI, so I obviously have all the correct data files, but all versions of the game get the same error when running them from the command line.
Am I missing an extra command line argument somewhere, or is the problem with line 77 in the above mentioned made.ccp? I'm not a programmer, so I'm afraid I couldn't make head nor tails out of the actual code.

Any help would be greatly appreciated.
Last edited by SixOfTwelve on Fri Sep 08, 2017 10:21 pm, edited 1 time in total.

User avatar
ScummVM Developer
Posts: 629
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Fri Sep 08, 2017 8:47 pm

I can reproduce the issue, but it works if I use made instead of rtz:

Code: Select all

e:\emulators\scummvm\scummvm --path=f:\roms\scummvm\rtz -f made
Or, if you have already added the game to ScummVM, and is thus listed in the launcher, you can get the game ID for it by looking at the game settings and use this. In such a case you don't even need to provide the path. For me the IS is rtz-cd:

Code: Select all

e:\emulators\scummvm\scummvm -f rtz-cd

Posts: 2
Joined: Mon Sep 04, 2017 4:33 pm

Post by SixOfTwelve » Fri Sep 08, 2017 10:20 pm

It worked! Thank you so much!

Post Reply