how to disable scaling

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Post Reply
poweredjj
Posts: 4
Joined: Fri May 19, 2017 12:50 pm

how to disable scaling

Post by poweredjj » Sat May 20, 2017 9:54 am

Hello, this is my first post in this forum :D.

I have a problem with Wii version of Scummvm. When using 240p unfiltered "double strike" mode on a crt, there is always some scaling enabled. How should I precisely set the horizontal and vertical underscan to disable scaling at all and get 1:1 pixel mapping?
Right now I always end up with more or less line doubling / line cutting - which looks terrible and defeats the whole purpose of playing on a crt television.
Is there any "secret" setting or maybe an exact underscan value?

Rikcahrd
Posts: 10
Joined: Sat Jul 04, 2009 6:42 pm

Post by Rikcahrd » Tue May 30, 2017 3:23 pm

What are your exact graphics settings in scummvm and in the ini file.
Just to be clear, you are getting scanlines with less flicker but the output is being scaled and fuzzier.

poweredjj
Posts: 4
Joined: Fri May 19, 2017 12:50 pm

Post by poweredjj » Wed May 31, 2017 3:43 pm

I'm using version 1.9.0.

Options:
graphics mode: double-strike
render mode: <default> (changing this doesn't help)
aspect ratio correction on (changing to off gives me squashed picture)
fullscreen mode on
horizontal and vertical underscan at default (changing to minimum or maximum doesn't help)

Double strike mode starts correctly - I'm getting low res picture with visible scanlines.

The image should look like this - every pixel is displayed once.
PC version of Scummvm displays it correctly at "1x" setting.
No duplication, no line cutting:
Image

Instead, it looks like one of the following cases.

With underscan set to higher values, some lines are duplicated:
Image


With underscan set to lower values, some lines are cut:
Image

Default underscan setting (slider at the middle) gives me some line duplication - it is no equivalent of "no scaling" option.

Setting the graphics mode to "double strike - filtered" eliminates line doubling / cutting, but the whole picture is blurry - it looks completely different than the pixel perfect artwork designed for low res tv screens.

My ini file looks like this:
[scummvm]
mute=false
speech_volume=192
native_mt32=false
mt32_device=null
midi_gain=100
talkspeed=60
gfx_mode=ds
subtitles=false
multi_midi=false
fullscreen=true
gui_browser_show_hidden=false
render_mode=hercAmber
browser_lastpath=sd:/apps/scummvm/games
gm_device=null
sfx_volume=192
music_volume=192
speech_mute=false
lastselectedgame=gob3-us
music_driver=auto
opl_driver=auto
aspect_ratio=true
versioninfo=1.9.0
autosave_period=300
gui_language=C
enable_gs=false

[plugin_files]
gob=plugins/gob.plg

[gob3-us]
description=Goblins Quest 3 (DOS/English (US))
path=sd:/apps/scummvm/games/goblins 3
gameid=gob
language=us
platform=pc
guioptions=sndNoSubs sndNoSpeech launchNoLoad lang_English (US)

Rikcahrd
Posts: 10
Joined: Sat Jul 04, 2009 6:42 pm

Post by Rikcahrd » Mon Jun 05, 2017 12:27 am

Originally posted by AReim1982
Update!
->

http://www.mediafire.com/file/y01mvf9ya ... wii-b3.zip

News:
- updated toolchain: devkitPPC R28 + LibOGC 1.8.16 + LibFAT 1.1.0
- updated libraries: Freetype 2.7, Jpeg 9B, LibPNG 1.5.28, ZLib 1.2.11, FLAC 1.2.1, LibMAD 0.15.1b, Tremor
- support for Z-Vision engine (Zork Nemesis, Zork Grand Inquisitor)

------------------------------------------------------

Download the above version and try it again. The nightly and and 1.9 versions from the bot are still using very old (2012) versions of the libraries. The above version by AReim1982 is updated with the latest versions.

poweredjj
Posts: 4
Joined: Fri May 19, 2017 12:50 pm

Post by poweredjj » Mon Jun 05, 2017 2:43 pm

I've tested this version, trying to change aspect ratio, full screen, screen mode...
The problem is identical to the previous version - no improvement.
There is always some horizontal and vertical scaling.

Post Reply