Scaling above 3x for a authentic, fullscreen experience

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

User avatar
criezy
ScummVM Developer
Posts: 549
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Wed Jul 18, 2018 6:59 pm

Strange.

I just downloaded the latest development build for "MacOS X (Intel)" from buildbot and tested it on macOS Sierra, and also downloaded the "Windows (64 bits)" from buildbot as well as the "Win32 Daily Snapshot" provided by Kirben on our download page and tested those on Windows 10. For me the stretch mode with OpenGL works properly for all of those both when resizing manually the window or using fullscreen mode.

One thing to note is that the ScummVM launcher itself always uses the full window/screen without any stretch or scaling as it is always directly displayed at the window (or screen in fullscreen mode) resolution. So the stretch mode will have no impact on the launcher itself. Also if you see black bars in the launcher this means that they are added by your graphics card (see below).

By default in fullscreen mode ScummVM uses the desktop resolution. But you can change it using Ctrl+Alt+plus/minus. And the last resolution used is stored in the config file and is used again the next time you start ScummVM. One possibility is that you have in the past set ScummVM to use a lower resolution than your desktop screen resolution, possibly one that has a different aspect ratio than your screen and causes your graphic card to add black bars. If I use 1600x1200 resolution for example, my graphic card does add black bars on the side of my screen, and the resolution that ScummVM sees is 1600x1200 so all stretch mode, except the Center one, give me the same display for 320x200 games with aspect ratio on.

Another thing to check would be that you have not overridden the graphics settings for the game you are trying to play.

Finally note that you can use the Ctrl+Alt+S shortcut to cycle through the stretch modes and test changing those while playing a game.

User avatar
KainXVIII
Posts: 42
Joined: Mon Feb 11, 2008 10:00 pm
Location: Russia

Post by KainXVIII » Wed Jul 18, 2018 8:39 pm

Well, stretch modes works if i press Ctrl+Alt+S, but not if set them in game options. Maybe i need to make fresh install of ScummVM or something, i will try to sort it out.
PS - at least it works with key combo!

Post Reply