ScummVM 1.8.0 for PowerPC Mac?

Ask for help with ScummVM problems

Moderator: ScummVM Team

Shadow
Posts: 10
Joined: Sat Apr 17, 2010 10:43 am
Location: Germany

ScummVM 1.8.0 for PowerPC Mac?

Post by Shadow » Tue Mar 22, 2016 5:30 pm

I'd like to ask you, if there's a 1.8.0 PowerPC/Mac-Download available? Thanks for your help!

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Re: ScummVM 1.8.0 for PowerPC Mac?

Post by LordHoto » Fri Mar 25, 2016 6:08 pm

Shadow wrote:I'd like to ask you, if there's a 1.8.0 PowerPC/Mac-Download available? Thanks for your help!
There is not at this point. It is unclear whether there will be another Macintosh PowerPC release at this point.

alesi
Posts: 2
Joined: Mon Apr 11, 2016 5:27 pm

Post by alesi » Mon Apr 11, 2016 7:28 pm

Sad news... just bought an eMac G4 for scummvm...

ScummBoy

Post by ScummBoy » Sun May 29, 2016 8:21 pm

This are really sad news... :cry:

But I still hope, maybe you'll give us a last kind of farewell release :wink:

User avatar
sev
ScummVM Lead
Posts: 1967
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev » Sun May 29, 2016 9:36 pm

ScummBoy wrote: But I still hope, maybe you'll give us a last kind of farewell release :wink:
It is unclear why you are asking LordHoto about this.

Historically the universal binaries were provided by Oystein Eftevaag aka vinterstum, who is not active for many months now.


Eugene

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon May 30, 2016 2:01 am

Hello,

I have a good news for you. I am the one compiling OS X releases now, and I have been working on bringing back PPC builds. I didn't want to comment before knowing if I would succeed or not, but I now have a build of ScummVM 1.8.1 for PowerPC macs and I need somebody to test it (I was only able to test it on an Intel mac with Rosetta). It should work on MacOS X 10.4 or more recent. Please try it and let me know if it works. If it does, it will be added to the download page.

Edit: it is now available on our download page
Last edited by criezy on Mon May 30, 2016 12:51 pm, edited 1 time in total.

ScummBoy

Post by ScummBoy » Mon May 30, 2016 11:55 am

sev wrote:It is unclear why you are asking LordHoto about this.

Historically the universal binaries were provided by Oystein Eftevaag aka vinterstum, who is not active for many months now.


Eugene
I'm sorry, such was not my intention.

criezy wrote:Hello,

I have a good news for you. I am the one compiling OS X releases now, and I have been working on bringing back PPC builds. I didn't want to comment before knowing if I would succeed or not, but I now have a build of ScummVM 1.8.1 for PowerPC macs and I need somebody to test it (I was only able to test it on an Intel mac with Rosetta). It should work on MacOS X 10.4 or more recent. Please try it and let me know if it works. If it does, it will be added to the download page.

For now you can find it at: https://www.dropbox.com/s/y8f8wotw6bois ... c.dmg?dl=0
Thank you :D

I'm running your version with OS X 10.5.8 on a G4 Powerbook.
Fired up some compressed LucasArts games (Dott, Dig, Indy 4,...). Played around with CoreAudio, loaded a few SoundFonts - no trouble at all.
Also tested the new Beavis and Butt-head in Virtual Stupidity game for a few minutes - saved a state and loaded it with no issues so far.

A good release *thumbs up*

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon May 30, 2016 12:10 pm

Great! Thank you for confirming it works :D

fm2
Posts: 6
Joined: Sun Apr 10, 2016 8:42 pm

Post by fm2 » Mon May 30, 2016 8:53 pm

iBook G3/800, Mac OS X 10.4.11. ScummVM 1.8.1 not started.

DelX
Posts: 5
Joined: Sat Jun 11, 2016 10:01 pm

Post by DelX » Sun Jun 12, 2016 9:57 am

Thank you so much! Works without any issues on my ibook G4 ppc on OSX 10.5.11

@fm2 you need to post more details, any error message or logs? Without it your post is pretty much pointless and does nothing to find the issue.

Regarding the previous poster, maybe it was compiled with flags for G4/ G5 CPUs? As far as I recall G3 CPUs had no altivec!? But the slow ppc machines can use any optimization they can get and it works beautiful here.

So nothing on the buildbot? But I'm happy the stable build is back, thank you so much!

Couldn't find commits on the osx ppc build and news don't mention it either, more details on what was wrong and how you fixed it would be appreciated.

On another topic, pswd reset for accounts on the forum are still broken and I suspect many potential posters give up when they can't get access to the forums with any of their many accounts (I by now must have 3 or 4) and their email adresses are already used so they can't make a new one on here either,...

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Sun Jun 12, 2016 11:28 am

The issue with the PPC build was with the toolchain used to build it and not with the ScummVM source code. As the executable grew bigger with the addition of new engines it hit a limit and this caused relocation error when building the application. In theory the use of -mlongcall should have fixed this, but because of a bug in the compiler it was still not working.

For this release I used a more recent toolchain and it worked. The reason you didn't see any related commit is because there is none (since there was no change to the source code) and the reason it is not mentioned in the ScummVM 1.8.1 release news post is because at the time we wrote this post I didn't know if I would get a working one or not.

I will try to look at the issue on MacOS X 10.4 this week and hopefully I can find out what is wrong. But more information on the issue would definitely be welcome.

fm2
Posts: 6
Joined: Sun Apr 10, 2016 8:42 pm

Post by fm2 » Mon Jun 13, 2016 6:07 pm

DelX wrote:@fm2 you need to post more details, any error message or logs? Without it your post is pretty much pointless and does nothing to find the issue.
iBook G3/800 14", VRAM 32M, RAM expanded to 640M (max), Mac OS 10.4.11

ScummVM 1.4.1 - 1.7.0 OK, 1.8.1 not started. No messages. Logs? Where can I find the logs?

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon Jun 13, 2016 10:26 pm

fm2 wrote:ScummVM 1.4.1 - 1.7.0 OK, 1.8.1 not started. No messages. Logs? Where can I find the logs?
Please have a look at FAQ 5.6 to see if that helps you find error messages.

fm2
Posts: 6
Joined: Sun Apr 10, 2016 8:42 pm

Post by fm2 » Tue Jun 14, 2016 6:21 am

OK, I find it. No error messages in scummvm.log, only about successfully started/closed 1.7.0 version.

User avatar
criezy
ScummVM Developer
Posts: 551
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Tue Jun 14, 2016 12:34 pm

Yes, I am not surprised that there is no message in the scummvm.log file since I suspect ScummVM fails to start before the point where it creates the log file.
What would be useful to me is if you get messages in Console.app (or when trying to start ScummVM from the terminal) as described in the second paragraph of the FAQ 5.6.

Post Reply