ScummVM 1.8.0-git for iOS 7+ available on GitHub

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Post Reply
Aasern82
Posts: 7
Joined: Tue Nov 01, 2016 9:36 pm

Post by Aasern82 » Sun Nov 06, 2016 10:18 pm

criezy wrote:Aasern82: I am getting those six semantic issues and the Info.plist warning as well, and I don't think they are the cause of ScummVM not being copied to your iPad. But I have no idea what the cause is. A wild guess maybe: have you checked you have sufficient available space on the iPad?

bobbygiovannucci: Are you following the instruction from the blog post here: http://blog.pmlabs-apps.com/scummvm-on- ... jailbreak/?
Criezy: iPad Air 2 with 64 gb, and lots of space available, so that shouldn't be the problem.

I really have no idea how to get any further, I have followed the instructions from A to Z. I think it's very strange that the build obviously is succeeding, but nothing seems to happen on the iPad. Could it be that doing this thru VirtualBox Manager isn't possible? Maybe I have to do this thru a Mac?

User avatar
bobbygiovannucci
Posts: 10
Joined: Fri Jun 17, 2016 8:15 pm

Post by bobbygiovannucci » Sun Nov 06, 2016 11:36 pm

Yes I am Criezy. Not sure what I am doing wrong. Could it be that my macbook is too old? It is from 2009.

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon Nov 07, 2016 2:14 am

Aasern82 wrote:Could it be that doing this thru VirtualBox Manager isn't possible? Maybe I have to do this thru a Mac?
That might indeed be the issue. I have no other idea in any case.

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Mon Nov 07, 2016 2:20 am

bobbygiovannucci wrote:Yes I am Criezy. Not sure what I am doing wrong. Could it be that my macbook is too old? It is from 2009.
Could you give more details on the error you are getting. For now I will assume that you are still getting the one you reported in your other thread:

Code: Select all

./prepare_workspace.sh: line 1: create_project: command not found
That one is a bit strange because create_project is not used on line 1. It is used on line 19, but it should be generated previously on line 10. Are you sure you copied the full prepare_workspace.sh script from the blog post and not just the last line?

mvickers03
Posts: 4
Joined: Sun Nov 06, 2016 12:12 pm

Post by mvickers03 » Mon Nov 07, 2016 5:31 pm

Hi,

I have an iPad 1, I got ScummVM 1.7.0 running yesterday from the archives,

My iPad is running iOS 5.1.1 old I know but seeing how good ScummVM 1.7 is running I really don't want to replace it, as I am likely only going to be playing adventure games on it.

Has anyone got a new build I can install on it? the touchpad could really use some tweaking in the build I'm using but apart from that is running great! I nearly finished Broken Sword 1 last night :)

I'd really like to try out this new build if it can be compiled for my device. Anyone willing to help?

User avatar
bobbygiovannucci
Posts: 10
Joined: Fri Jun 17, 2016 8:15 pm

Post by bobbygiovannucci » Tue Nov 08, 2016 12:06 am

Hi Criezy. I got past the error I posted about earlier. Right now i am waiting for the ipad mini 4 to be prepped for installation. It turns out I missed some lines while copying the code. I will let you know if I have anymore errors.

User avatar
bobbygiovannucci
Posts: 10
Joined: Fri Jun 17, 2016 8:15 pm

Post by bobbygiovannucci » Fri Nov 18, 2016 7:19 pm

hi Criezy when i got past the preparing of my ipad it would not build because i missed a few lines in the prepare_workspace.sh file. I will try again when I have more time to do so. I basically missed the same lines the other poster in this thread missed. I will update you when I make my next attempt.

User avatar
bobbygiovannucci
Posts: 10
Joined: Fri Jun 17, 2016 8:15 pm

Post by bobbygiovannucci » Fri Nov 25, 2016 4:32 pm

Criezy I got it to load onto my ipad mini 4 without any problems. Now I got to figure out how to load the games I own onto my iPad mini 4. I will let you know if it works once I copy the files from my original cds and download the ones I own from gog and steam.

Mahssel
Posts: 3
Joined: Fri Jan 20, 2017 9:01 am

Post by Mahssel » Fri Jan 20, 2017 12:21 pm

Hi,

Today I tried to compile Scummvm for my iPhone 6s not jailbroken.

Im running OS X Sierra in a virtual machine.

First of all the script worked fine and Xcode started.

My Phone is connected to the virtual machine an showed up in iTunes.

Then I tried compiling scummvm. I got 10 semantic warnings and one error:
scummvm/scummvm/engines/fullpipe/utils.h:45:10: Cast from pointer to smaller type 'uint' (aka 'unsigned int') loses information
This is what Xcode tells me. Hopefully one of you can help me solving this problem

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Fri Jan 20, 2017 9:21 pm

The code on which you get the error was added fairly recently (4 months ago), and the engine was not enabled by default until early December. I think I did compile the code for iOS more recently than that however. I will have to give it a go again to check if I get this error as well.

From the error I would guess that you are compiling a 64 bits application (which is normal for iOS), but that the configure script didn't properly detect you are using 64 bits. That might maybe be related to how your VM is configured.

But you can simply not compile the fullpipe engine. You will not be able to use it anyway on iOS as it it a fairly recent game and uses more than 256 colours (while currently ScummVM on iOS can only run games that use 256 colours or less).

Now that I think about this, it should already be disabled when compiling for iOS. The instructions everyone is following has a prepare_workspace.sh script that runs create_project with --disable-16bit, and that should disable the fullpipe engine. Maybe check that your script is correct. You can also try editing it to also add

Code: Select all

--disable-engine=fullpipe
on that same line, but that should not be needed.

Mahssel
Posts: 3
Joined: Fri Jan 20, 2017 9:01 am

Post by Mahssel » Sat Jan 21, 2017 1:22 pm

Thx criezy that solved THIS error.

Afterwards i got the error mentioned here. So i took the hint you gave there and added it to the prepare_workspace.sh. And after letting the bash running there was no error anymore.
And i got scummvm installed on my iPad pro.

Thanks therefore

/edit:

Scummvm Works. Indiana Jones and the Fate of Atlantis is starting and playable. But i can do no settings about sound or stuff. and i don't get any sound output.
Any ideas about that?

Mahssel
Posts: 3
Joined: Fri Jan 20, 2017 9:01 am

Post by Mahssel » Mon Jan 23, 2017 8:16 am

Funny about this problem is:

I compiled Scumm for my iPhone 6s (same IOS 10.2) and there i can heare the sound and can change the settings.

Perhaps i need to recompile scum for my iPad and make exact the same setting for compiling (if there were any difference at the first time)

/Edit:
even compiling the app for iphone and using it on the ipad doesn't make the sound appear.

Anybody an idea about this?

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Wed Feb 01, 2017 12:35 am

I finally found the time to compile ScummVM with the latest for my iPad, and I can confirm that I am also getting the error in full pipe (and that we need to explicitly disable the fullpipe engine as I suggested).

Regarding the sound issue, I have no idea what the problem might be. I have no issue on my iPad Air (with iOS 10.2).

Ihros
Posts: 3
Joined: Fri Feb 10, 2017 8:29 am

Post by Ihros » Sun Feb 12, 2017 12:03 pm

criezy wrote:
Aasern82 wrote:Could it be that doing this thru VirtualBox Manager isn't possible? Maybe I have to do this thru a Mac?
That might indeed be the issue. I have no other idea in any case.
Just for the record: I have successfully installed scummvm on my ipad air 2 via El Capitan running on vmware.

Ihros
Posts: 3
Joined: Fri Feb 10, 2017 8:29 am

Post by Ihros » Sat Feb 18, 2017 2:41 pm

After ScummVM worked flawlessly in my iPad for two weeks, yesterday i got this message when i stared the app.
What could possibly be wrong? Any way to repair it, or do i have to repeat the installation procedure?

Image

Post Reply