AROS trying to bring 1.3 Up to Date (non coding expert)

Discussion about other and unofficial ports of ScummVM

Moderator: ScummVM Team

Post Reply
XDelusion
Posts: 11
Joined: Tue Feb 08, 2011 8:26 am

AROS trying to bring 1.3 Up to Date (non coding expert)

Post by XDelusion » Fri Feb 06, 2015 10:43 pm

Hello, I am running the AROS distribution IcarOS 2.0.3.

http://vmwaros.blogspot.com/

Since IcarOS 1.5, I have been trying desperately to compile ScummVM 1.6 and now 1.7 since AROS only has access to 1.3.
Sadly this has always ended with failure as it seems that each time I get a unique error that, from what I can tell, takes place near the end of the compilation, and during the compiling of the GUI code.

I asked the guy who ported ScummVM to MorphOS (a similar OS) what he did to get it to compile and he said ./configure and of course make, and it just worked.

http://www.morphos-team.net/

Now if anyone is interested in trying to trouble shoot this with me, I can provide the errors I am getting, but in the mean time, is there something I can simply comment out in order to bypass the GUI all together and use this as a command line tool?

Thanks in advance!

digitall
ScummVM Developer
Posts: 963
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sat Feb 07, 2015 6:22 pm

Please just post the error... We can't really debug by hearsay.

XDelusion
Posts: 11
Joined: Tue Feb 08, 2011 8:26 am

Post by XDelusion » Tue Feb 10, 2015 12:23 am

Alright, thank you!


I can not seem to get my shell to output all the text to the log file, instead the parts with the error show up within shell, so I have taken a screen shot showing off the error that happens after I have ran the "make" command and let it run for a good while.


Image

digitall
ScummVM Developer
Posts: 963
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Tue Feb 10, 2015 11:01 am

That is a Linker error, so all the code modules compiled, but fail to link due to missing symbols.

The first missing symbol, gScummVMFullVersion is defined in scummvm/base/version.cpp. Maybe libbase.a has been omitted from your link for some reason?

XDelusion
Posts: 11
Joined: Tue Feb 08, 2011 8:26 am

Post by XDelusion » Tue Feb 10, 2015 2:12 pm

EDIT: Thanks, I'll look into "/base/version.cpp" tonight.

XDelusion
Posts: 11
Joined: Tue Feb 08, 2011 8:26 am

Post by XDelusion » Wed Feb 11, 2015 1:34 am

All right, fist and foremost, I do not know what a linker is, or what language that is, I presume it is a coding term, or is it something specific to ScummVM?

The Modules, I believe are what are responsible for getting the games to load in the first place, am I correct?

As for Symbols, I'm not sure what "symbols" are, and again there is the term "link", so I presume by "linking" you mean connecting the symbols and or modules to the rest of the parts of ScummVM or just together in general?

As for version.cpp, I opened it, and found the section designated to gScummVMFullVersion, though within there, I did not see any reference to "libbase.a" nor do I see such a file with the ScummVM sources.

Back to gScummVMFullVersion. Is that the only error in the image I posted, it is the only Symbol listed, and all the messages below it errors relating to that alone, or...

thank you again!

digitall
ScummVM Developer
Posts: 963
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed Feb 11, 2015 11:25 pm

https://en.wikipedia.org/wiki/Linker_%28computing%29

To be honest, if you are not comfortable with compilers, linkers and Make, I wouldn't suggest that you use a Research Operating System such as AROS.

Post Reply