Test-Candidate of ScummVM 2.0.0 for WII

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Post Reply
47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Tue May 13, 2014 4:42 pm

Well the red and black background was only in the ScummVM background, not in any games that I know of.

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Tue May 13, 2014 5:16 pm

The bug name is slightly misleading. The effect was observed in several FM-TOWNS games with the mouse cursor, but it turned out to be a backend bug related to certain graphics surfaces with color keying. Anyway, *shrug* it is fixed now and seems to have fixed your observed issues.

47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Tue May 13, 2014 7:48 pm

The only problem I have now is that SOMI ultimate talkie edition has no voice overs, also flac doesn't work but mp3 does.

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Tue May 13, 2014 8:02 pm

That is probably because libflac is not compiled on the buildbot for the Wii toolchain. I will take a look at that.

47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Tue May 13, 2014 8:51 pm

digitall wrote:That is probably because libflac is not compiled on the buildbot for the Wii toolchain. I will take a look at that.
Thanks

AReim1982
Posts: 36
Joined: Tue Dec 10, 2013 1:56 pm
Location: Germany

Post by AReim1982 » Wed May 14, 2014 9:15 am

@digitall: My inofficial ScummVM 1.6-Release already contains libflac. Please ask me if you need help with compiling libflac.

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed May 14, 2014 9:24 am

@AReim1982: Thanks. Any major pitfalls?

Did you use v1.2.1 and the patches from here? http://wiki.scummvm.org/index.php/Compi ... M/Wii#FLAC

47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Wed May 14, 2014 1:58 pm

Hopefully I'm not confusing anyone here, 1.6.0 does have flac support, just not the 1.7 git revisions.

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed May 14, 2014 2:30 pm

47iscool: That is probably because the v1.6.0 build on the buildbot was made prior to the toolchain being updated (and thus the libraries were rebuilt).

The stable nightly builds are only performed if there has been a code change within the last 24 hours. As the stable release branch has not had any backports recently, a rebuild is not performed.

AReim1982
Posts: 36
Joined: Tue Dec 10, 2013 1:56 pm
Location: Germany

Post by AReim1982 » Wed May 14, 2014 6:58 pm

@digitall:
yes, if you follow that tutorial, libflac should compile fine.
p.s.: somebody should update that tutorial [ not me, because my english is too bad... :-) ]

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sat May 17, 2014 9:41 pm

libflac should now be installed on the buildbot Wii toolchain. Will need to check the next nightly.

47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Sun May 18, 2014 3:46 am

Not sure if it's considered a problem or but, pressing shift plus another button on the virtual keyboard doesn't work. It just presses the second button instead and removes the shift from the line at the top which displays which buttons you want to press.

Also, does a USB keyboard and/or mouse work with ScummVM?

47iscool
Posts: 48
Joined: Mon May 12, 2014 4:04 am
Location: United States

Post by 47iscool » Sun May 18, 2014 8:29 am

Start game,edit game options or trying to edit the default settings for every game gives a DSI error.

Version: wii-master-bee54dc0

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun May 18, 2014 10:32 am

Hmm.. libflac doesn't seem to have been picked up the nightly. Will have to check how it was built and whether there is any issue with the location for detecting it.

47iscool: As far as I know, a USB keyboard and mouse should work. Not sure why that occurs with the Virtual Keyboard. I don't think I saw that or the DSI error when I last tested. Will check here on my Wii.

digitall
ScummVM Developer
Posts: 964
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun May 18, 2014 4:45 pm

Tested with a slightly older v1.7.0git6276 "known good" build.

This supports USB hubs and USB keyboards within ScummVM for text input. However, USB mice don't seem to work. They also don't work in the System Menu or HBC.

Post Reply