AGA scummVM and Roland MT-32

Discussion about other and unofficial ports of ScummVM

Moderator: ScummVM Team

Post Reply
grinder
Posts: 3
Joined: Wed Nov 20, 2013 7:40 am

AGA scummVM and Roland MT-32

Post by grinder » Wed Nov 20, 2013 8:06 am

Hello, is it possible to use real hardware for sound, in my case the Roland mt-32?
I was thinking to connect the A1200 with the Roland, in order to play via scummvm the monkey island 1 & 2 of the pc VGA 256 colour versions.
Setup is :
A1200 (blizzard 1230/50Mhz +FPU, 64MB)
Roland mt-32
1084 monitor (I read that vga monitor needed, is it correct?)
OS: classic Workbench

Thanks

digitall
ScummVM Developer
Posts: 952
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed Nov 20, 2013 1:29 pm

As I indicated on:
http://wiki.scummvm.org/index.php/Platf ... _Platforms

The ScummVM port to original Amigas is unofficial and not supported. The latest appears to be based on v1.4.1.

If you can select Options->MIDI->GM Device:SEQ and Options->MIDI->MT-32 Device:SEQ, this should send MIDI data to the standard default MIDI interface in the Operating System (assuming the backend code for Amiga has been implemented).

I would test this with a software synth firstly. If this works, then a MT-32 connected with a standard MIDI cable and correctly configured in the Amiga OS should work, but this is totally unknown if this is even possible:
http://en.wikipedia.org/wiki/Amiga_1200 ... _expansion

Let us know if you get this working...

grinder
Posts: 3
Joined: Wed Nov 20, 2013 7:40 am

Post by grinder » Wed Nov 20, 2013 5:31 pm

Thanks for the reply!

grinder
Posts: 3
Joined: Wed Nov 20, 2013 7:40 am

Post by grinder » Mon Dec 02, 2013 8:52 am

Sorry for the delay, but I have a problem when I’m trying to load a game…I’m getting the following message…
“scummvm program error
wait for disk activity to finish. suspend/reboot”
I tried with different hard drives, OS, filesystem, but nothing…

digitall
ScummVM Developer
Posts: 952
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Mon Dec 02, 2013 11:31 am

grinder: Sorry, not a clue what that means or why it is happening.

As I said, this is an outdated and unofficial port and so your mileage may vary. If you can find any required source code patches and a toolchain, you may be able to compile and port the latest code to original Amiga, but otherwise you are stuck.

NovaCoder
Posts: 74
Joined: Wed Sep 23, 2009 11:53 pm

Post by NovaCoder » Tue Jun 02, 2015 12:11 am

Version 1.6.0 ported to Classic Amiga, this version will support native MIDI (eg MT-32) for the first time :D

This will be my last port of ScummVM to Classic Amiga, I'm moving on to other things and leaving the Amiga scene.

I didn't even attempt to port 1.7.0 as I know that a lot of changes have been made between version 1.6.0 and 1.7.0 and it only just about compiles now (my DEV tools are ancient!).

https://www.youtube.com/watch?v=PLibxH9 ... e=youtu.be

digitall
ScummVM Developer
Posts: 952
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed Jun 03, 2015 1:22 am

NovaCoder: Thanks for this. I can't see any newer version on Aminet. Could you provide any required source patches against v1.6.0, a quick build HOWTO and your final v1.6.0 build for mirroring before you leave the scene please?

NovaCoder
Posts: 74
Joined: Wed Sep 23, 2009 11:53 pm

Post by NovaCoder » Wed Jun 03, 2015 6:23 am

digitall wrote:NovaCoder: Thanks for this. I can't see any newer version on Aminet. Could you provide any required source patches against v1.6.0, a quick build HOWTO and your final v1.6.0 build for mirroring before you leave the scene please?
No problems :)

Just got to finish testing then I'll be uploading to AmiNet with sources, hopefully early next week.

Post Reply