WME Testing-thread

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

User avatar
somaen
ScummVM Developer
Posts: 47
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen » Tue Nov 19, 2013 10:16 pm

RP: Regarding your edit: was the bug about scrolling not true, or was there a difference between the versions.

Regarding the DVD-version: Could you give me a full file-listing for the game-folder there (including subfolders), I need to know the structure to know how to handle the languages there.

As for the naming, I tend to prefer to use the english name for consistency (adding (Czech) after), mostly because we don't have support for varying game-naming across languages, unless I complicate my detection-tables quite a bit. (Not to mention handling multiple codepages in the launcher, which afaik is stuck in ISO8859-1, but I might be wrong).

I guess there is some possibility to argue over which is the correct naming though, as the game is czech-made.

RP
Posts: 3
Joined: Tue Nov 19, 2013 7:24 am

Post by RP » Tue Nov 19, 2013 11:19 pm

This is the list of files after instalation:

Code: Select all

data.dcp
Five magical amulets.url
game.exe
launcher.exe
unins000.dat
unins000.exe
language
language\czech.dcp
language\english.dcp
readme
readme\readmeCZ.html
readme\readmeEN.html
readme\src
readme\src\border.gif
readme\src\l1.jpg
readme\src\l2.jpg
readme\src\list.jpg
readme\src\menu.jpg
readme\src\noha.jpg
readme\src\ovl.jpg
readme\src\ovl2.jpg
It's the same list as the downloaded version (only some files are different).

When I run the launcher.exe, one of language files (czech.dcp or english.dcp) is copied to the main directory - based on which language is chosen.

When I run "Check for updates" in the launcher, patch1.dcp is downloaded to the main directory.

Regarding the bug about scrolling:
I played the game from the beginning until the bug. I was saving along the way - I saved it right after being teleported to the ice land, then I discovered the bug.

When I was testing it today, I discovered that:
When I load the mentioned savegame, the scrolling doesn't work.
When I load an earlier savegame and play to the ice land, the scrolling works.

It works like that in both versions - DVD and downloaded. (I renamed the saves from the DVD version to load them in downloaded version.)

Blokatt
Posts: 3
Joined: Sat Nov 16, 2013 1:42 pm
Location: Czech Republic
Contact:

Post by Blokatt » Wed Nov 20, 2013 6:18 pm

Ok, about Dead City:
All languages show up in the selection menu (when adding the game to the list), but no matter what language is selected, the game is in English every time I start it.
And also, you can't change the language later in the "Edit" menu, it's just grayed out.

Silencer
Posts: 1
Joined: Thu Nov 21, 2013 6:06 pm

Post by Silencer » Thu Nov 21, 2013 6:11 pm

Hi,

I completed Dirty Split English version without noticable bugs.

User avatar
somaen
ScummVM Developer
Posts: 47
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen » Fri Nov 22, 2013 3:00 pm

Blokatt wrote:Ok, about Dead City:
All languages show up in the selection menu (when adding the game to the list), but no matter what language is selected, the game is in English every time I start it.
And also, you can't change the language later in the "Edit" menu, it's just grayed out.
Is there by chance an english.dcp in your gamefolder (not counting the one in the language/ subfolder)?

Blokatt
Posts: 3
Joined: Sat Nov 16, 2013 1:42 pm
Location: Czech Republic
Contact:

Post by Blokatt » Fri Nov 22, 2013 8:36 pm

Nope.

Code: Select all

********************************
C:\Program Files (x86)\Dead City
********************************
 
     .                                               0     20.11.2013 19:20:52     ----D-
     ..                                              0     20.11.2013 19:20:52     ----D-
     data.dcp                                  9070205     6.7.2005 18:19:56     -----A
     deadcity.exe                              1974272     6.7.2005 18:19:50     -----A
     language                                        0     20.11.2013 19:20:52     ----D-
     launcher.exe                              1077248     6.7.2005 9:30:22     -----A
     readme                                          0     6.11.2013 13:59:38     ----D-
     settings.exe                                49152     23.5.2005 22:14:20     -----A
     unins000.dat                                 2409     6.11.2013 13:59:38     -----A
     unins000.exe                               669677     6.11.2013 13:59:32     -----A
 
*****************************************
C:\Program Files (x86)\Dead City\language
*****************************************
 
     .                                               0     20.11.2013 19:20:52     ----D-
     ..                                              0     20.11.2013 19:20:52     ----D-
     english.dcp                                415935     6.7.2005 18:19:50     -----A
     italian.dcp                                454037     6.7.2005 18:19:50     -----A
     russian.dcp                                653317     6.7.2005 18:19:50     -----A
 

User avatar
zxthehedgehog42
Posts: 3
Joined: Thu Nov 28, 2013 7:15 pm

Post by zxthehedgehog42 » Thu Nov 28, 2013 7:21 pm

I just tested on iPhone, Dirty Split gives me a message that says it could not initialize color format and crashes.
Currently running iOS 6 on an iPhone 3GS.
Same game install works on Windows build fully.

Threepwood
Posts: 15
Joined: Tue May 30, 2006 1:16 pm

Post by Threepwood » Thu Dec 19, 2013 11:40 am

I tried to start some of the Wintermute games with the daily snapshot. It seems that a file called "wintermute.zip" is missing. Where can I get it?

JenniBee
Posts: 68
Joined: Fri Sep 17, 2010 5:22 am

Post by JenniBee » Thu Dec 19, 2013 6:36 pm

Threepwood wrote:I tried to start some of the Wintermute games with the daily snapshot. It seems that a file called "wintermute.zip" is missing. Where can I get it?
You can get the latest version from here (just click on View Raw).

User avatar
misterhands
Posts: 20
Joined: Thu Oct 25, 2012 12:37 pm
Location: France

Post by misterhands » Fri Jan 10, 2014 6:25 pm

Completed Dirty Split with some bugs, all posted on the tracker.

Saving the game seems quite slow (4-5s) vs instant in the original.

User avatar
misterhands
Posts: 20
Joined: Thu Oct 25, 2012 12:37 pm
Location: France

Post by misterhands » Fri Jan 10, 2014 6:27 pm

Also, any comment on my Theora question Somaen?

User avatar
somaen
ScummVM Developer
Posts: 47
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen » Sat Jan 11, 2014 4:27 pm

Feel free to post the Theora-bug.

Thanks for the Dirty Split-bugs, I have added detection-entries for the french/spanish/czech/italian-versions now, and a possible fix was found for the "ghosting"-issues you posted about.

User avatar
misterhands
Posts: 20
Joined: Thu Oct 25, 2012 12:37 pm
Location: France

Post by misterhands » Fri Jan 17, 2014 5:02 pm

Done.

I've completed 5 Lethal Demons, and made a bug report about missing text in message boxes.
According to the wiki it's a known issue, but I figured it can't hurt to report it!

Thanks

lillemask
Posts: 21
Joined: Thu Jan 23, 2014 2:05 pm

Post by lillemask » Fri Jan 24, 2014 8:18 am

I'm playing Rosemary with Scummvm osx_intel-master-3fd28f31, but it crashes at a certain point asking for missing font files. Maybe this is a stupid question, but where exactly should I put the included fonts? I've tried activating them in my system and placing them in various locations, but to no avail. Also, is there supposed to be an intro movie? I didn't see one.

User avatar
somaen
ScummVM Developer
Posts: 47
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen » Fri Jan 24, 2014 6:46 pm

Could you tell me exactly which fonts it asks for, when?

Post Reply