Dreamweb not running on latest dev/stable build

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Post Reply
scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Dreamweb not running on latest dev/stable build

Post by scorp256 » Sun Sep 01, 2013 8:46 am

Just tried both versions, floppy and cd, always show black screen and nothing else. Does anyone know how to fix it?

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun Sep 01, 2013 11:50 am

Firstly, we would need more information. Exactly which development build from buildbot are you using? ie. v1.7.0git-xxxxx .

This is shown on the launcher screen below the ScummVM logo.

Also, which IOS device are you running this on?

This sounds like it could be a screensize issue as Dreamweb starts in 640x480 before dropping to 320x200...

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Sun Sep 01, 2013 1:24 pm

Forum tells message is spam o_O sent mail to admin... it is 1.7.0git1609 and ipad1 iOS5.0.1, in games I tried LoL, The Dig, LoK 1-3 - works correctly. Is there any logging in this build?

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun Sep 01, 2013 3:32 pm

Yes, there should be logging of errors and messages enabled to a log file in $HOME/.scummvm/logs if I read the code correctly... otherwise search around the paths given here to see if you can find the logs directory:
https://github.com/scummvm/scummvm/blob ... ADME#L1946

If not, I may have to fix the logging function as I'm not sure it was ever tested on IOS...

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Sun Sep 01, 2013 8:00 pm

Actually found in /private/var/mobile/.scummvm.log

But there is nothing :(

Code: Select all

User picked target 'dreamweb-cd' (gameid 'dreamweb')...
  Looking for a plugin supporting this gameid... DreamWeb engine
  Starting 'DreamWeb'

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun Sep 01, 2013 10:38 pm

Hmm... Either it is crashing out (You would have to link a remote GDB session to your tablet which is heavy magic ie. I don't know how to do this and I don't think our debugging HOWTO covers this)... Though you aren't getting the debug messages as -d 10 or similar isn't passed on command line... as there is no command line. Need to work out a way of passing that parameter for command line less targets ie. Android, IOS etc.

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Fri Sep 06, 2013 11:41 am

Seems need someone to compile a test build, having that debug options setted up... In any case - is this port supported by anyone officially? Means who we can ask for this.

And did you please try this yourself, if it works for you (as Dreamweb is for free download here on site)?

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Fri Sep 06, 2013 12:33 pm

Well, you would normally compile and debug this yourself if you are capable:
http://wiki.scummvm.org/index.php/Compi ... mVM/iPhone
http://wiki.scummvm.org/index.php/Debugging_ScummVM

Apart from that, you could try talking to the IPhone maintainer... who is listed here:
http://wiki.scummvm.org/index.php/IPhone

And I can't try this myself.. as I do not own any IOS devices.
I am just providing basic user support and bug "triage"...

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Tue Sep 10, 2013 12:01 pm

Yes, unfortunately you're right, I seems not able to compile that things... Need someone more skilled.

Wrote PM to vinterstum, but not sure, if he will ever read it, as did not saw any posts from him recently...

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Tue Sep 10, 2013 10:03 pm

I would suggest that an e-mail is more likely to invoke a response as I don't think he is very active on the forums.

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Tue Sep 17, 2013 6:30 pm

I did not found his email, do you know it?

digitall
ScummVM Developer
Posts: 954
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Tue Sep 17, 2013 6:38 pm

Sigh... A search of the scummvm-devel mailing list archive would show that his e-mail as of his last message is oystein@NOREDMEATgeheb.com (removing the obvious SPAM blocking section). This message was "Re: [Scummvm-devel] Mac OSX Supported Versions" sent on 23/11/12 03:49. I would suggest trying vinterstum@NOREDMEATusers.sourceforge.net as well...

scorp256
Posts: 7
Joined: Sun Sep 01, 2013 8:41 am

Post by scorp256 » Sat Jun 16, 2018 12:21 am

Maybe something changed and somebody could speak with vintersturm? :)

I tried latest build from buildbot (july 16 2018) and same...

I suppose this could be related to resolution changes in game (as it first is 640x480, the game itself is 320x200 iirc), at least I saw it this way on PC. Maybe IOS tries to change resolution to 640 as well, instead of upscaling and fails? I suppose there should be other games with similar problems.

Post Reply