v1.6.0 not available in Android Market ?

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

User avatar
Mister Floppy
Posts: 3
Joined: Sat Nov 19, 2005 9:37 am

v1.6.0 not available in Android Market ?

Post by Mister Floppy »

Hi,

why is v1.6.0 not available in Android Market?

Regards,

Mister Floppy

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Simply because the Android maintainer has not packaged and released it yet... There is some lag after v1.6.0 source release for various porters to provide their builds.

Though you are correct that the Downloads page is in error, as the Market still only has v1.5.0, not v1.6.0

But I have no date for when this will be released. I will poke the Android team.

karsten
Posts: 14
Joined: Sun Feb 05, 2006 11:59 am

Post by karsten »

digitall wrote:I will poke the Android team.
Could you poke them again? It's almost three months since the announcement.

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

OK... Have talked to fuzzie about this.

This has been due to Google Play (The new name for the Marketplace) giving very cryptic error messages when we
try to submit the upgraded build... and a lack of time for
the porter to fight with the app store.

In order to avoid this in future, we are going to provide
the v1.6.0 and future builds as a zipfile of the signed apks for download on our downloads page in addition to a link to Google Play:
http://www.scummvm.org/downloads/?p=downloads

We will then try again to work out why Google are giving us problems...

I should point out that you can also download the v1.6 branch stable or v1.7 development autogenerated builds from the buildbot: http://buildbot.scummvm.org/builds.html

You need to uninstall all previous versions of ScummVM before you can install a buildbot build.

Also, you need to enable "Installation of third party applications" in the Settings menu during the installation as these apks are not signed.

Nazo
Posts: 11
Joined: Sun Sep 01, 2013 8:38 am

Post by Nazo »

digitall wrote:I should point out that you can also download the v1.6 branch stable or v1.7 development autogenerated builds from the buildbot
File missing error when I click stable. Is there any source at all for 1.6.0 stable or does it exist nowhere except on the maintainer's system?

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Nazo: Sorry about this. The buildbot box keeps a number of snapshots of builds, not just the latest linked on the builds page. The link to this is at the top of this page:
http://buildbot.scummvm.org/builds.html
where it says (all):
http://buildbot.scummvm.org/snapshots/

Anyway, to ensure that the box doesn't run out of disk space, a script runs periodically to purge snapshots older than 1 week. Unfortunately, as nightly builds are only performed if there has been a commit in the last 24 hours, the stable builds can age to the point where all builds are removed.

This is a bug (The script should check and not remove if only 1 set of builds is present)... I need to look at fixing it.

For now, please use the v1.7.0git development snapshots.
I will trigger a manual nightly v1.6.0 build and look at changing the script code to preserve the final build...

Nazo
Posts: 11
Joined: Sun Sep 01, 2013 8:38 am

Post by Nazo »

I guess your manual trigger worked. When I checked just now it gave me 1.6.0pre82-gbd42dee dated today, which I'm guessing is essentially the stable version, right? At the very least it should be more stable than the 1.7 nightly surely.

I've seen Google's useless errors first-hand before btw. I've been fighting with an app called Name Generator for ages (great for generating names for character creation in games) which just says "App not installed" when I try to install it with no details whatsoever. How they thought it was a good idea to not give the user something usable as an error message is beyond me entirely, but clearly Google isn't thinking ahead when it comes to error messages... More recently it started saying "app cannot be installed in the default install location" which is still pretty useless as all of my searches on what could cause this come back to ancient 2.x Android versions from back when some people had to install in a very limited internal partition and none of the solutions still applies today whatsoever. Thus still an equally useless error message...

karsten
Posts: 14
Joined: Sun Feb 05, 2006 11:59 am

Post by karsten »

@digitall

Thanks for the information.

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

@Nazo: Yes, the manual trigger has restored the v1.6.0 stable build... Stable and development are a bit of misnomer.

We rarely have major regressions in the main development "master" trunk in Git, but it is possible.. so hence these builds are recommended only to Developers, Power Users and other people who like to live on the edge... The worst they are likely to do is corrupt your ./scummvmrc configuration file, but they could crash or do nasty stuff due to new bugs... although they also have a lot of fixes for older bugs since the last release... *SHRUG* Your mileage may vary.

The autogenerated stable builds are generated from the latest branch-1-x-x which occurs at feature freeze prior to release testing and are intended for testers and thus receive backports of bug fixes, but not further development work..

@Karsten: No problem... I tend to end up with the Tech Support hat on! :)

User avatar
MusicallyInspired
Posts: 1038
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired »

Aspect Ratio Correction no longer works in 1.6.

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

MusicallyInspired: In just the Android build (this is a thread in the Android Port forum...) or in all v1.6.0 builds?

User avatar
MusicallyInspired
Posts: 1038
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired »

I believe just Android but I'll double check later today.

EDIT: Ah, I only had to remove full screen. Nice to see the graphical glitches finally gone on the sides as well!

Les
Posts: 32
Joined: Thu Feb 03, 2011 1:52 pm
Location: Slovakia

Stable version

Post by Les »

Hi Guys, hm, I'm trying for several days to download the stable version but no luck. Whas up with that link? Thanks for help.

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Les... Please try reading the thread first... I answered your question on 1st Sep at 08.46am in my post. I added a fix to the cleanup script, but this is a little complex abd it appears it is still not working ... Will trigger a manual, debug the script and retest. SIGH.

digitall
ScummVM Developer
Posts: 1017
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Right... have debugged and tested the build cleanup script. I had made two minor errors, which resulted in the stable still be overzealously cleaned... and the master failed to be cleaned at all! *facepalm* Fixed now and should stay fixed. Manual build of stable running... so stable build links will be restored shortly.

Post Reply