3 Skulls of the Toltecs

Subforum for discussion and help with ScummVM's Maemo (Nokia N800/N810/N900) port

Moderator: ScummVM Team

Post Reply
Smothermunchie
Posts: 96
Joined: Fri Mar 30, 2007 10:00 pm

3 Skulls of the Toltecs

Post by Smothermunchie » Fri Jan 11, 2013 4:31 am

Hey Tarek.

I'm using the Demo version to this game found here:
http://sourceforge.net/projects/scummvm ... p/download

And I'm also using your latest build:
scummvm 1.6.0~git2468.g550a169 armel.deb

Anyway, at the start up, there's some kind of glitchy sound through the speakers and it eventually brings me to the title screen.

Image

After this SCUMM because unresponsive.

Closing it from the Task Manager doesn't seem to kill SCUMM.

Neither does killall hildon-desktop or killall scummvm.

At one point I had three scummvms running on my tablet when I used the command "top" so I decided to reboot.

Just thought you might want to know this.

Cheers buddy. :)

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Jan 11, 2013 5:30 am

Same thing happens to me

Since there's no pkill here's what to do (as root):

Code: Select all

# killall -kill scummvm
Please log a bug. I'll look into it.

Debug output (looks like an infinite loop?)

Smothermunchie
Posts: 96
Joined: Fri Mar 30, 2007 10:00 pm

Post by Smothermunchie » Fri Jan 11, 2013 6:59 am

killall -kill scummvm
Thanks for the command line. :)

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3303
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Fri Jan 11, 2013 7:16 am

tsoliman wrote: Debug output (looks like an infinite loop?)
Certainly looks like it. Perhaps the loop in Screen::drawGuiTextMulti() never terminates, for whatever reason?

User avatar
Addison
Posts: 4
Joined: Fri Jan 11, 2013 7:03 am

Post by Addison » Fri Jan 11, 2013 7:18 am

I'm sorry, but where and how do I log a bug again for the Maemo port?

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Jan 11, 2013 7:20 am

Addison wrote:I'm sorry, but where and how do I log a bug again for the Maemo port?
Same as all bugs: http://sourceforge.net/tracker/?group_i ... tid=418820

There's a link to this URL in the main website called bug tracker.
Last edited by tsoliman on Fri Jan 11, 2013 7:24 am, edited 2 times in total.

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Jan 11, 2013 7:22 am

eriktorbjorn wrote:
tsoliman wrote: Debug output (looks like an infinite loop?)
Certainly looks like it. Perhaps the loop in Screen::drawGuiTextMulti() never terminates, for whatever reason?
Thanks for the tip. I'll debug more in the morning.

User avatar
Addison
Posts: 4
Joined: Fri Jan 11, 2013 7:03 am

Post by Addison » Fri Apr 05, 2013 12:55 pm

Demo still freezes.

Currently using version scummvm_1.6.0~git3565.g4b21ec2_armel

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Sun Apr 07, 2013 1:11 am

I am told that the full version does not freeze. Weird.

Post Reply