2.6 with eloader 0.96 wont work

Subforum for discussion and help with ScummVM's PSP (PlayStation Portable) port

Moderator: ScummVM Team

Post Reply
phish
Posts: 4
Joined: Sun Apr 02, 2006 11:32 am

2.6 with eloader 0.96 wont work

Post by phish » Sun Apr 02, 2006 11:35 am

I'm running firmware 2.6 (a stupid mistake i still regret), i've got the latest psp scummvm and i'm trying to run monkey island one and two. I've got e-loader 0.96 and GTA:LCS.

However every time i run ScummVm through e-loader i just get a black screen and then the psp turns itself off. This happens every single time regardless of which version of the ScummVm Eboot i use. It's doing my head in and any help would be much appreciated.

User avatar
Jimbob
Posts: 305
Joined: Mon Oct 31, 2005 4:36 pm
Location: Somewhere in the UK

Post by Jimbob » Sun Apr 02, 2006 11:53 am

One quick question comes to mind, can you run other homebrew software using this bootloader and firmware 2.6? I don't have a PSP so I won't be able to help at all.

phish
Posts: 4
Joined: Sun Apr 02, 2006 11:32 am

Post by phish » Sun Apr 02, 2006 3:38 pm

I haven't tried to be perfectly honest. I'm only interested in getting ScummVm working.

User avatar
Jimbob
Posts: 305
Joined: Mon Oct 31, 2005 4:36 pm
Location: Somewhere in the UK

Post by Jimbob » Sun Apr 02, 2006 3:56 pm

Well it may be that no homebrew is working on your PSP, hence no ScummVM. I noticed that version 0.97 of the Loader has been released as well, codename Boch or something .... you may want to try with that.

phish
Posts: 4
Joined: Sun Apr 02, 2006 11:32 am

Post by phish » Sun Apr 02, 2006 10:39 pm

Nope it doesn't work with 0.97 either. I'm thoroughly confused as everyone else reports no problems with running the latest ScummVm on 2.0 and above using GTA:LCS. :(

tbrown
Posts: 1
Joined: Mon Apr 03, 2006 3:46 pm

Post by tbrown » Mon Apr 03, 2006 3:51 pm

I have no problems with Scummvm 0.8.2 running on a 2.6 with 0.96 e-loader. However, the first version I tried was the special 333 mhz version, which doesn't work on my psp, but the standard version does.

MegaJim
Posts: 5
Joined: Fri Apr 07, 2006 11:40 pm

Post by MegaJim » Sat Apr 08, 2006 9:58 am

phish wrote:Nope it doesn't work with 0.97 either. I'm thoroughly confused as everyone else reports no problems with running the latest ScummVm on 2.0 and above using GTA:LCS. :(
Some things i would suggest :

Get latest eloader 0.97 and latest scummvm (222mhz seems to be more stable) 0.8.2

When installing, use the eboot designed for 1.0 FW psps (in a folder called single eboot in the scummvm release)

fanjita's Eloader sometimes won't let Eboots execute unless they are under a specified path, for scummvm i have found this is : PSP\GAMES\scummvm-psp\EBOOT.PBP

When loading fanjita's eloader i find it much more reliable if you use a save game of LCS from the very beginning of the game. Just start a new game and at first opportunity make a new save, always load this save before loading fanjita's eloader.

Final step i would suggest is confirm the data files for the game you are trying to run work correctly - i.e. get the windows (if you use windows) release of scummvm and load up the game in that to confirm it works correctly.

Good luck.

Post Reply