SVN FW 2.0

Subforum for discussion and help with ScummVM's PSP (PlayStation Portable) port

Moderator: ScummVM Team

Post Reply
User avatar
erwan
Posts: 40
Joined: Mon Oct 31, 2005 9:54 am
Location: Bretagne, France
Contact:

SVN FW 2.0

Post by erwan » Thu Mar 16, 2006 8:41 pm

Hello
You can test last version SVN for the FW 2.0 ( and 1.0, 1.5)
http://scummvm.dc-france.com/scummvm-psp.html

Support "the Lure of the Temptress engine" and "the Cinematique engine evo 1"

User avatar
joostp
ScummVM Developer
Posts: 490
Joined: Wed Sep 21, 2005 3:55 pm

Post by joostp » Thu Mar 16, 2006 9:15 pm

Euhm, what's the difference between the 1.00 and 2.00 builds?

User avatar
erwan
Posts: 40
Joined: Mon Oct 31, 2005 9:54 am
Location: Bretagne, France
Contact:

Post by erwan » Thu Mar 16, 2006 9:56 pm

Hello,
No, that depends on the version of your FIRWARE

1.0 Binairie for FW 1.00
2.0 Binairie for Loader (FW: 2.00 and +)

User avatar
joostp
ScummVM Developer
Posts: 490
Joined: Wed Sep 21, 2005 3:55 pm

Post by joostp » Thu Mar 16, 2006 10:21 pm

Yes, but what is the difference between those binaries?

Since 0.8.2 ScummVM runs in usermode by default, so the 1.00 EBOOT should run on 2.00+ via a loader and there should no longer be a need to build a seperate '2.00' version.
Your 1.00 and 2.00 versions seem to differ, so I want to know what you changed (and why).

User avatar
erwan
Posts: 40
Joined: Mon Oct 31, 2005 9:54 am
Location: Bretagne, France
Contact:

Post by erwan » Fri Mar 17, 2006 6:15 am

Code: Select all

//#define	USERSPACE_ONLY


/**
 * Define the module info section
 *
 * 2nd arg must 0x1000 so __init is executed in
 * kernelmode for our loaderInit function
 */
#ifndef USERSPACE_ONLY
PSP_MODULE_INFO("SCUMMVM-PSP", 0x1000, 1, 1);
#else
PSP_MODULE_INFO("SCUMMVM-PSP", 0, 1, 1);
#endif

User avatar
joostp
ScummVM Developer
Posts: 490
Joined: Wed Sep 21, 2005 3:55 pm

Post by joostp » Fri Mar 17, 2006 10:37 am

Well, USERSPACE_ONLY is defined by default in SVN now, since I've never received a valueable bug-report with info from the exception handler anyway and it makes it easier for the end-users (they can use any version, the only difference is the 1.00 vs. 1.50 EBOOT packaging).

User avatar
erwan
Posts: 40
Joined: Mon Oct 31, 2005 9:54 am
Location: Bretagne, France
Contact:

Post by erwan » Fri Mar 17, 2006 11:29 am

does version "1.00" function on a FW 2.00 ?
Last edited by erwan on Fri Mar 17, 2006 12:00 pm, edited 1 time in total.

User avatar
joostp
ScummVM Developer
Posts: 490
Joined: Wed Sep 21, 2005 3:55 pm

Post by joostp » Fri Mar 17, 2006 11:58 am

erwan wrote:does version "1.OO" function on a FW 2.00 ?
Yep, it should.
I don't have a 2.00+ PSP myself, but the 1.00FW 0.8.2 release seemingly works fine for most people with the loader.

User avatar
erwan
Posts: 40
Joined: Mon Oct 31, 2005 9:54 am
Location: Bretagne, France
Contact:

Post by erwan » Fri Mar 17, 2006 12:01 pm

ok, thank you

Post Reply