Myst on Android?

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Post Reply
vaxjedi
Posts: 1
Joined: Sun Apr 10, 2011 7:45 pm
Location: United States

Myst on Android?

Post by vaxjedi » Sun Apr 10, 2011 7:47 pm

I see that latest builds of ScummVM on the PC can run Myst. Can the Android port run Myst? I've tried installing it and it says no game found - I'm wondering if it is not supported yet or I am just messing something up ;) Thanx!

elektrolott
Posts: 5
Joined: Tue May 10, 2011 3:57 pm

Post by elektrolott » Tue May 10, 2011 4:13 pm

Hi, I had the same problem.

I downloaded the build from the buildbot yesterday, but if I try to run Myst or Riven I only get an error message Game data not found.

And I did install the mohawk.apk.

I then downloaded the debian lenny build from the buildbot and verified it had the same problem on my Linux box. On the commandline however it revealed that it seems that the support for Myst and Riven is not compiled in. The about page on android also shows Myst and Riven in 'grey' which I assume means it is missing.

I then built the Linux version from source and configured myst and riven and I could load the games OK.

Can the build bot be configured to build a working Mohawk engine for Myst and Riven for the next builds?

Thanks!

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Post by clone2727 » Wed May 11, 2011 12:24 pm

We're currently preparing for a release, so the only builds the buildbot is showing are the 1.3.0pre builds. You can still find the latest 1.4.0git build here.

elektrolott
Posts: 5
Joined: Tue May 10, 2011 3:57 pm

Post by elektrolott » Wed May 11, 2011 3:35 pm

clone2727 wrote:We're currently preparing for a release, so the only builds the buildbot is showing are the 1.3.0pre builds. You can still find the latest 1.4.0git build here.
Thanks for the link. I installed it and it works :D

chuckflynn
Posts: 2
Joined: Tue May 24, 2011 4:02 am

Post by chuckflynn » Tue May 24, 2011 4:09 am

Hi .. I have spent a lot of time trying to get Myst working also. I tried to follow the link to get the 1.4.0git build that was mentioned above but it keeps saying that I am not authorized. Any help in getting this release would be greatly appreciated. Thanks

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Tue May 24, 2011 7:43 am

The old 1.4.0git test builds have been rotated out by the system automatically by now.. we are currently gearing up for the 1.3 release and hence are fully focused on that. Once it is out of the door, we will resume providing test builds of 1.4.0git. Until then, we'd appreciate if people could test the 1.3.0pre builds as much as possible, so that we get a good and solid 1.3.0 release :)

chuckflynn
Posts: 2
Joined: Tue May 24, 2011 4:02 am

Post by chuckflynn » Tue May 24, 2011 1:50 pm

Thank you very much for your quick response.
Since I am only interested in Myst and Riven, if I check every day for a test build of 1.4.0git, will it have Myst and Riven enabled?

elektrolott
Posts: 5
Joined: Tue May 10, 2011 3:57 pm

Post by elektrolott » Wed Jun 01, 2011 9:50 pm

The Download latest development build link at http://buildbot.scummvm.org/builds.html still works for me and it contains files with todays date. I did not try to install the download, but I would assume it should work.

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Thu Jun 02, 2011 10:07 am

Just to clear this up: I re-enabled the daily development builds only yesterday. So two days ago, the link you are talking about did not exist :).

Philum
Posts: 2
Joined: Thu Oct 13, 2011 8:52 pm

Mohawk Engine for Android

Post by Philum » Thu Oct 13, 2011 9:07 pm

Where would I find the Mohawk (Living Books) engine for Android?

I see that the other engines are listed in the Market but not Mohawk. Is it not yet available?

Thank you.

spiderpc
Posts: 2
Joined: Sun May 25, 2014 8:03 pm

Post by spiderpc » Sun May 25, 2014 8:26 pm

Hi,

I downloaded latest development build from buildbot for Android ARM and I installed scummvm.apk and scummvm-engine-mohawk.apk.

I created a folder with required data files for Myst Masterpiece, I started scummvm, I added folder of data files but when I start the game I get the following error: "ERROR: PICTDecoder::decodeCompressedQuickTime(): Could not decode data! "

I am using a LG E975, Android 4.1.2.

Is there something I'm missing in order to run Myst on my LG?

digitall
ScummVM Developer
Posts: 1009
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun May 25, 2014 9:36 pm

Oh damn. libjpeg is not present in the Android ARM build or is not being picked up, so Myst ME which uses JPEG in the PICT image files will fail with this error:
http://buildbot.scummvm.org/builders/ma ... logs/stdio

Will look at adding this missing library to the Android toolchains on the buildbot.

digitall
ScummVM Developer
Posts: 1009
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Sun May 25, 2014 11:28 pm

@spiderpc: Fixed. This should be picked up in the next nightly development build. Could you confirm if this is working or not after testing with this? Thanks.

spiderpc
Posts: 2
Joined: Sun May 25, 2014 8:03 pm

Post by spiderpc » Mon May 26, 2014 5:34 am

I took latest build, released on 26-May-2014 05:15, and error is not encountered anymore. Thanks for the quick fix. :wink:

Post Reply