libvpx7 dependency

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
Mustrum
Posts: 95
Joined: Wed Jan 28, 2009 2:06 pm
Location: Ankh-Morpork
Contact:

libvpx7 dependency

Post by Mustrum »

I wonder why ScummVM (Daily Build/master branch) depends strictly on libvpx7 and not on a higher version.
Currently libvpx7 is only available for Debian/stable (bookworm) but not more for Debian/unstable. Debian unstable/sid currently uses libvpx8 and/or libvpx9.

With libvpx9 installed, but without libvpx7, ScummVM does not start. The console says:

Code: Select all

./scummvm: error while loading shared libraries: libvpx.so.7: cannot open shared object file: No such file or directory
Currently I have libvpx9 installed with manual symlink from libvpx.so.9 to libvpx.so.7

Code: Select all

ln -s /usr/lib/x86_64-linux-gnu/libvpx.so.9 /usr/lib/x86_64-linux-gnu/libvpx.so.7
This works, but the symlink should not be, because a working libvpx9 is already installed.

Better would be a dependency query like libvpx7 >= or so.

Edit: I found the check for VP8/VP9 Decoder here:
https://github.com/scummvm/scummvm/blob ... gure#L5397
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3537
Joined: Mon Oct 31, 2005 7:39 am

Re: libvpx7 dependency

Post by eriktorbjorn »

The daily build seems to be linked against libvpx7 but I've had no problems compiling ScummVM on Debian unstable, where it seems to link against libvpx9 for me.
User avatar
sev
ScummVM Lead
Posts: 2283
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Re: libvpx7 dependency

Post by sev »

We do not require any specific version of libvpx. As you saw in the testing code, it does not check the version.

Our buildbot runs on a specific machine, and it just happens that libvpx7 is installed there. Some developer has to update the libraries on the buildbot.


Eugene
Post Reply