Crashing as soon as I load application

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
helpmac
Posts: 1
Joined: Fri Jan 06, 2023 6:48 am

Crashing as soon as I load application

Post by helpmac »

I just downloaded the newest version of SCUMMVM for MacOs I have a M1 chip and everytime I go to open SCUMMVM I get an error saying check to make sure SCUMMVM has been updated for MacOS. The actual error I'm getting is this:

Dyld Error Message:
Symbol not found: __ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE5closeEv
Referenced from: /Applications/ScummVM.app/Contents/MacOS/scummvm (which was built for Mac OS X 12.0)
Expected in: /usr/lib/libc++.1.dylib

Anyone know how to fix this?
User avatar
Praetorian
ScummVM Developer
Posts: 599
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: Crashing as soon as I load application

Post by Praetorian »

helpmac wrote: Fri Jan 06, 2023 7:35 pm I just downloaded the newest version of SCUMMVM for MacOs I have a M1 chip and everytime I go to open SCUMMVM I get an error saying check to make sure SCUMMVM has been updated for MacOS. The actual error I'm getting is this:

Dyld Error Message:
Symbol not found: __ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE5closeEv
Referenced from: /Applications/ScummVM.app/Contents/MacOS/scummvm (which was built for Mac OS X 12.0)
Expected in: /usr/lib/libc++.1.dylib

Anyone know how to fix this?
Hello, can you verify that you have downloaded this installer: " macOS 10.9+ for Intel and Apple Silicon, with Sparkle Disk Image (98.9 MiB .dmg, last update: 2022-10-29" from the ScummVM downloads page?
User avatar
criezy
ScummVM Developer
Posts: 902
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: Crashing as soon as I load application

Post by criezy »

Are you maybe on macOS Big Sur (macOS 11)? I may have made a mistake with the compilation of the last release, and I am not sure the Apple Silicon version works on Big Sur. It may require macOS Monterey or Ventura (macOS 12 or 13). If that is the case it should work if you run ScummVM with Rosetta to use the Intel version of the app.
  1. Select ScummVM.app, and then press Command-I (or right-click/use the File menu and select Get Info.). This will open an Info window with details about the app.
  2. In the Info window, look for a checkbox labeled, “Open using Rosetta”. Check the box.
  3. Then close the window and try to start ScummVM again.
Post Reply