SCUMMVM for iOS 9.3.5 or 10.3.3

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Post Reply
Steveseg
Posts: 2
Joined: Sun Jan 03, 2021 6:44 pm

SCUMMVM for iOS 9.3.5 or 10.3.3

Post by Steveseg »

Hello,
I jailbroke an iPad mini (1st gen) running iOS 9.3.5 and an iPad 4 running iOS 10.3.3 using the 3U tool. In Cydia I've installed UrbanFanatics, but don't see SCUMMVM under Games. I've downloaded the SCUMMVM deb and ipa files, but I'm not sure what to do with them. Can some one explain how to install SCUMMVM thanks? I've already copied the game I want to play, The Dig, to both devices.

Thanks,
Steve
User avatar
sev
ScummVM Lead
Posts: 2078
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Re: SCUMMVM for iOS 9.3.5 or 10.3.3

Post by sev »

Please try to follow these instructions: https://docs.scummvm.org/en/latest/othe ... m-firmware

Also, it would be awesome if you tell whether it worked as is or we need to update the manual.


Eugene
Steveseg
Posts: 2
Joined: Sun Jan 03, 2021 6:44 pm

Re: SCUMMVM for iOS 9.3.5 or 10.3.3

Post by Steveseg »

I really wanted to use my iPad mini with iOS 9.3.3. I read somewhere that I needed version 1.8.1 of SCUMMVM, so I downloaded the .deb file from the Downloads page (https://www.alvinpoh.com/installing-and ... pod-touch/). I then followed the instructions at

https://www.thegeeksclub.com/how-to-ins ... %20More%20

to install the .deb file and it worked. On my Mac I used Cyberduck to place the deb file in root/private/var/tmp folder.

Is there a chart or source that says the minimum iOS requirements for each version of SCUMMVM?

Thanks

All this to play The Dig :-)
User avatar
criezy
ScummVM Developer
Posts: 775
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: SCUMMVM for iOS 9.3.5 or 10.3.3

Post by criezy »

Steveseg wrote: Tue Jan 12, 2021 1:44 amIs there a chart or source that says the minimum iOS requirements for each version of SCUMMVM?
Not really. But our download page (https://www.scummvm.org/downloads/) at least indicates the mininmum iOS requirements for the latest release. So for example currently, for ScummVM 2.2.0, it indicates iOS 8+ package, which means it should work on iOS 8.0 or above (and we also have a separate package for iOS 3 and above in case you have a very old device).

The information for past releases is no longer there (although we have it in our source code repository). But indeed it could be a good idea to keep track of this somewhere convenient.

In any case the latest release should work on your iOS 9 and 10 devices (and if you have an older one, we also have a package for iOS 3 or above).
Post Reply