Blade Runner WIP

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
User avatar
Raziel
ScummVM Porter
Posts: 1078
Joined: Tue Oct 25, 2005 8:27 am
Location: a story that hasn't been written yet

Re: Blade Runner WIP

Post by Raziel » Mon Mar 25, 2019 12:48 pm

Yep, working great for music now :-)

Thanks a lot

peterkohaut
Posts: 10
Joined: Tue Sep 13, 2016 4:51 pm

Re: Blade Runner WIP

Post by peterkohaut » Mon Mar 25, 2019 10:52 pm

For that "stripping" I suspect some floating point rounding issues, but it might be related to z-buffer as well.
Please, can you try to run "draw zbuf" in debug console? it should render zbuffer instead of color.
I was trying to get amigaos 4.0 working with winuae & ppc qemu plugin, but i was not very lucky yet.

User avatar
Raziel
ScummVM Porter
Posts: 1078
Joined: Tue Oct 25, 2005 8:27 am
Location: a story that hasn't been written yet

Re: Blade Runner WIP

Post by Raziel » Mon Mar 25, 2019 11:12 pm

It says Drawing Z buffer = 1 and then displays this picture, unfortunately, ego is still behind the objects.

Image

If i could help you with the OS4 installation, just shout, otherwise throw those debug builds at me :-)

peterkohaut
Posts: 10
Joined: Tue Sep 13, 2016 4:51 pm

Re: Blade Runner WIP

Post by peterkohaut » Mon Mar 25, 2019 11:48 pm

....maybe it will be not needed, I just did some dirty hacking, and I can get almost the same artifacts (striping on actors), looks like it related to endianes as well.

Praetorian
ScummVM Developer
Posts: 63
Joined: Tue May 08, 2007 8:54 am

Re: Blade Runner WIP

Post by Praetorian » Thu Apr 11, 2019 8:26 am

Quick update on this one about the Big Endian platforms; The z-ordering issue along with drawing issues for images should be fixed in commits by peterkohaut (since a few days now actually), so please test and verify if you are on one of such platforms. And also report any other issues you've encountered :)

User avatar
Raziel
ScummVM Porter
Posts: 1078
Joined: Tue Oct 25, 2005 8:27 am
Location: a story that hasn't been written yet

Re: Blade Runner WIP

Post by Raziel » Thu Apr 11, 2019 8:28 am

@Preatorian

Awesome...sound and z-ordering fixed in AmigaOS4 :-D

Praetorian
ScummVM Developer
Posts: 63
Joined: Tue May 08, 2007 8:54 am

Re: Blade Runner WIP

Post by Praetorian » Thu Apr 11, 2019 9:27 am

Raziel wrote:
Thu Apr 11, 2019 8:28 am
@Preatorian

Awesome...sound and z-ordering fixed in AmigaOS4 :-D
Excellent, thank you for confirming.
Let us know of any other issues that you may encounter.

Post Reply