MIDI sound problems in Monkey Island 2

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
CCLGamer
Posts: 4
Joined: Wed Jan 31, 2018 7:41 pm

MIDI sound problems in Monkey Island 2

Post by CCLGamer » Thu Feb 01, 2018 7:30 pm

I am using Windows 10 with CoolSoft VirtualMidiSynth driver with a 1GB Sound font file. I have downloaded Monkey Island 2 Main theme melody as a midi file, and it plays perfectly with the timber flutes in a midi player like Audacity. It compares to YouTube videos demonstrating true MT32 sound with Monkey Island 2.
https://www.youtube.com/watch?v=ZOSY-a2wZzM

But, somehow ScummVM 2.0.0 sends something horrible to the midi driver messing up the flutes. I have tried sending it to MT32 without emulation, using a virtual MIDI port LoopBe1 that sends it to VirtualMidiSynth.

Is there a way to play the music as well as my midi players play midi on VirtualMidiSynth?
Last edited by CCLGamer on Fri Feb 02, 2018 9:17 pm, edited 1 time in total.

User avatar
Raziel
ScummVM Porter
Posts: 1013
Joined: Tue Oct 25, 2005 8:27 am
Location: A haunted Castle somewhere in the Bavarian Mountains
Contact:

Post by Raziel » Fri Feb 02, 2018 6:05 pm

Where have you downloaded Monkey Island 2?

CCLGamer
Posts: 4
Joined: Wed Jan 31, 2018 7:41 pm

Post by CCLGamer » Fri Feb 02, 2018 7:57 pm

Raziel wrote:Where have you downloaded Monkey Island 2?
I like to use original disks and files, instead of downloading.

There is nothing wrong with the game. It both plays and sounds perfectly in DOSBOX with midiconfig set to 3 (Munt “MT-32 Synth Emulator” on my computer)

For some reason, I can't get scummvm to sound anything like MT32, when using MT32 emulation. That is why I was interested in sending it to the VirtualMidiSynth driver. In fact, no matter which MIDI port I use, I get the same horrendous midi metallic sounding music.

User avatar
Raziel
ScummVM Porter
Posts: 1013
Joined: Tue Oct 25, 2005 8:27 am
Location: A haunted Castle somewhere in the Bavarian Mountains
Contact:

Post by Raziel » Sat Feb 03, 2018 7:58 am

Hmm, i'm not sure if the MT-32 emulation in ScummVM even work without the ROM files.

I guess you have those ROMs?
MT32_PCM.ROM and MT32_CONTROL.ROM

Maybe someone else with Windows knowledge will chime in, i'm not much of help here.

CCLGamer
Posts: 4
Joined: Wed Jan 31, 2018 7:41 pm

Post by CCLGamer » Sat Feb 03, 2018 10:43 am

Raziel wrote:Hmm, i'm not sure if the MT-32 emulation in ScummVM even work without the ROM files.

I guess you have those ROMs?
MT32_PCM.ROM and MT32_CONTROL.ROM

Maybe someone else with Windows knowledge will chime in, i'm not much of help here.
Yes, I have the ROM files, and the latest MUNT works fine with them. However, I understand scummvm uses its own built in MUNT, so i placed rom files inside scummvm directory and defined that to be extra path.

User avatar
MusicallyInspired
Posts: 991
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired » Sat Feb 03, 2018 4:59 pm

So in ScummVM options under Audio and the "Preferred Device" dropdown menu, you have selected "MT-32 Emulator?" Also in the MT-32 tab the "MT-32 Device" dropdown menu must be set to "MT-32 Emulator" as well. And tick the checkbox that says "True Roland MT-32 (disable GM emulation)" and DON'T check "Roland GS Device (enable MT-32 mappings)".

CCLGamer
Posts: 4
Joined: Wed Jan 31, 2018 7:41 pm

Post by CCLGamer » Sun Feb 04, 2018 1:59 am

MusicallyInspired wrote:So in ScummVM options under Audio and the "Preferred Device" dropdown menu, you have selected "MT-32 Emulator?" Also in the MT-32 tab the "MT-32 Device" dropdown menu must be set to "MT-32 Emulator" as well. And tick the checkbox that says "True Roland MT-32 (disable GM emulation)" and DON'T check "Roland GS Device (enable MT-32 mappings)".
Yes, I did have this in the options. However, I am using external Munt device MT-32 Synth Emulator [Windows MIDI], which is now communicating with ScummVM due to the following change. While going through your instructions, I also decided to edit the game and chose to override with the same settings, and now it works. For some reason the game settings were overriding the ScummVM options. So no matter what I chose in options, there was no change. I was stuck with the same horrible sound. Thank you for your help. I am terribly sorry for wasting time.

User avatar
MusicallyInspired
Posts: 991
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired » Mon Feb 05, 2018 6:07 am

Game settings always override ScummVM global settings.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3303
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Mon Feb 05, 2018 6:21 am

Raziel wrote:Where have you downloaded Monkey Island 2?
Just as a side note, I thought he meant he downloaded a MIDI of the Monkey Island 2 theme music, not the game itself.

Unless it was just recorded directly from the game, I assume it was rearranged to sound good as General MIDI as described - for instance - in the HighLand Productions FAQ.

The time when I understood all of the MIDI settings in ScummVM has come and gone, so I won't try to answer the actual question. :-)

Post Reply