Double keystrokes

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
2097
Posts: 2
Joined: Thu Dec 21, 2017 12:33 pm

Double keystrokes

Post by 2097 » Fri Dec 22, 2017 11:52 am

I'm playing Police Quest 4 on ScummVM 2.0.0 on Debian and I get double keystrokes. Now, I wouldn't mind if there was no problem other than my save files being named "tteesstt" but you have to type in the game as well.
Any ideas about this?

I installed Flight of the Amazon Queen just to test and it has the same problem.

bgK
ScummVM Developer
Posts: 11
Joined: Sat Feb 13, 2016 12:40 pm

Post by bgK » Fri Dec 22, 2017 3:56 pm

Do you have an IME (fcitx, ...) enabled? If so, please try disabling it (or run scummvm with XMODIFIERS=@im=none).

SDL 2.0.5 from Debian is known to duplicate key presses when an IME is enabled.

2097
Posts: 2
Joined: Thu Dec 21, 2017 12:33 pm

Post by 2097 » Fri Dec 22, 2017 6:27 pm

Thanks!
That was the issue. For future reference (if someone finds this thread), running scummvm from the command line like this:

Code: Select all

XMODIFIERS='@im=none' scummvm
fixed the issue for me.

Thank you bgK.

Post Reply