I need help with Lighthouse and Phantasmagoria 2 please

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
appollo147
Posts: 11
Joined: Sun Dec 26, 2010 10:33 pm

I need help with Lighthouse and Phantasmagoria 2 please

Post by appollo147 » Tue Dec 05, 2017 4:41 pm

I am testing the new nightly build of ScummVM 2.1.0.0 and I really need some help packaging Lighthouse and Phantasmagoria 2 so I can play them on ScummVM. The instructions for those two games are as of yet not available on the ScummVM Wiki which is why I am asking for help here. I would really appreciate some simple step-by-step instructions on what files need to be copied from my cds, and where I need to place them. I tried reading the general instructions for multi-disc games on the Wiki, but I found them to be a little confusing. Any help with this would be greatly appreciated.

User avatar
criezy
ScummVM Developer
Posts: 550
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Tue Dec 05, 2017 5:00 pm

The instructions on the wiki for these two games seem pretty clear to me:
  • Create a directory for this game on your computer.
  • Copy all files from all CDs to the previously created game directory.
  • Rename the RESOURCE.SFX from each CD to RESSFX.00<cdnumber> (so for example RESSFX.001 for the one from the first CD), and the RESOURCE.AUD from each CD to RESAUD.00<cdnumber>.
  • The directory structure should be preserved and when you have a directory with the same name of multiple CDs merge them together (copy the files from that directory from each CD into a directory with the same name in the game directory). If a file with the same name exists in the same directory on multiple CDs you can just pick any one of those.
Which part exactly do you need help with?
I am not familiar with those games, but I trust the information on the wiki is correct.

User avatar
Longcat
Posts: 981
Joined: Sat Sep 23, 2006 3:15 pm

Post by Longcat » Tue Dec 05, 2017 6:57 pm

I can confirm that they are correct.

appollo147
Posts: 11
Joined: Sun Dec 26, 2010 10:33 pm

Post by appollo147 » Wed Dec 06, 2017 2:07 am

Thanks for the responses I figured out what I was doing wrong. I was naming the files wrong lol.

Post Reply