Call for beta testers

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Post Reply
User avatar
ScummVM Lead
Posts: 2052
Joined: Wed Sep 21, 2005 1:06 pm

Call for beta testers

Post by sev »

New beta, for Android was released.

We fixed SD card access and removed the system cursor.

Could you please try the new beta at: ... vm.scummvm and provide your feedback?


Posts: 116
Joined: Fri Dec 09, 2005 10:11 am

Post by goetz »

Thanks for releasing this new beta. I have downloaded it via the Play Store beta program and was able to complete a game with it: Full Throttle, Version B/English. That game crashed on the recent SDL builds, while it ran fine on much older builds. But probably that is not the feedback you were expecting.

So far, ScummVM is running fine and no issues when accessing the file system. Maybe a minor one: When going to the root folder via "Go up" button, nothing is shown in the file chooser and you have to change the scummvm.ini as described elsewhere. So this is a known issue and a tiny one. Everything else seems to work fine.

For the control (mouse) mode, I used only the default direct mode, on the touch screen. Did not try the relative mode.

Device: Nexus 5X, Android 7.1.2 with latest (June) patch level

Posts: 116
Joined: Fri Dec 09, 2005 10:11 am

Post by goetz »

Update: On Google Pixel (32GB model) with Android 7.1.2, June Patch level, access to the file system seems to be working well, too. I have started a few scumm games and all seemed to be working well.

Posts: 1
Joined: Sat Jul 15, 2017 12:43 pm

Post by Mattax »

On Android 7.1.1 Sony Xperia X Compact:
I am testing the beta right now playing DOTT.

File System works good!

i am using the "relative mouse movement (laptop mode)" setting.
Speed at "Medium", acceleration at "Slow".
left-click is set to "Tap"
right-click is set to "hold at the same spot" for 1.0 second.

Basically trying to get the 1.7 Control back.

Bugs i noticed so far:
When trying to move the cursor a few pixel, scumm will perform a right-click, making precise pointing difficult. The cusor also tends to stutter when moved slowly.

i believe the problem is that the "hold at the same spot" function for the right click, has a high tolerance for what is considered the same spot and ingores slow movment, also when the cursor is moved slowly it will still check every second if "hold at the same spot in x sceond" is true.


Posts: 9
Joined: Fri Aug 11, 2017 7:12 am

Post by Larrynho »

Tested on S7 edge on Android 7.0

Tested LSL7.

Pops up a message at the game start that there are missing assets but the game seems to work ok ( I used to play using dosbox with that same installation ).

So far, so good... got game on SD card working at 100% speed with no seeming glitches neither audio nor graphics.

- No way to pop up keyboard (game needs manual verb input).
- Beta build on android is the "regular" non SDL ( play store version is )... any chance to get these beta features on the SDL build? ( more android friendly )

User avatar
Posts: 37
Joined: Sun Jun 03, 2012 11:09 pm
Location: Toronto, Canada

Post by scarmona »

Running on an older (but oh so sturdy) Samsung Galaxy Note 10.1 2014 Edition tablet with Android 5.1.1. The games look gorgeous on a big screen.
I love how the mouse tracking with the stylus has progressed in the last years with the SDL variant. Looking into getting a Note 8 and see how it runs ScummVM

Great performance overall, I mostly play LucasArts and Sierra games and I've found that I need to play around with the audio buffer to accommodate specific games with MT-32 emulation enabled (who in their right mind would disable this??):
  • - Very small: Some increased cracking and distortion in several games
    - Small: variable
    - Medium: minor impact
    - Large: Most games sound good, noticed audio delays on Full Throttle
Regardless of the buffer size I will hear some occasional cracking on all games, I guess/hope this is related to the device's processing power maybe? Other users can comment on this.

I noticed that I cannot enter certain characters using the built-in keyboard, for example: ! and :
Nothing happens after hitting shift and the specific key, if it shows a colon, I'll get a semicolon, if it's an exclamation mark, I'll get 1.
Is it possible to implement the ability to pull up the native android keyboard when in portrait mode and scale the game window accordingly? this would make a world of difference when playing Sierra AGI and SCI games.


Posts: 36
Joined: Tue Aug 22, 2017 7:55 am

Post by philthethrill »

I downloaded the latest development build on my Acer Chromebook 14 CB3-431 with Android 7.1.1, and I don't see the directory when I click Add Game.

Posts: 36
Joined: Tue Aug 22, 2017 7:55 am

Post by philthethrill »

I tried the latest stable build and I didn't see the directory either.

Posts: 36
Joined: Tue Aug 22, 2017 7:55 am

Post by philthethrill »

still not seeing the directory with the latest build. [/img]

Posts: 24
Joined: Fri May 23, 2008 11:31 am

Post by Spin »

MT-32 emulation works great, first build for me were it actually worked. However can't get The Secret of Monkey Island unofficial SE talkie and Riven to run, they run perfectly fine on my ScummVM git version on Arch Linux.

Tested on Samsung Note 3 with Lineage 14 upwards, Oneplus 5 with official stock OOS and Pure Fusion. I can confirm the SD card bug is fixed with this release, rolling back to 1.9.0 and the bug is present.

Post Reply