How to disable P for pause

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
extracampine
Posts: 5
Joined: Tue Apr 11, 2017 11:46 am

How to disable P for pause

Post by extracampine » Thu Apr 13, 2017 3:16 pm

When playing adventure games and typing a command (e.g. "open door"), whenever I press the "P" key the game pauses and the ScummVM menu comes up. This is obviously not how it should be - any help on why this is happening and how to stop it would be much appreciated!

Edit: this seems to happen when running ScummVM via RocketLauncher, and not when running it in isolation. Still keen for any pointers!

User avatar
corpse
Posts: 34
Joined: Sun Dec 18, 2005 5:28 pm
Location: uk

Post by corpse » Thu Apr 13, 2017 3:57 pm


extracampine
Posts: 5
Joined: Tue Apr 11, 2017 11:46 am

Post by extracampine » Fri Apr 14, 2017 4:04 pm

That link says to remap the key for the emulator:

1: In the bottom field, just click the green plus and it will tell you how it works (basically, press original key and then press the key it should act as instead). Keep pressing + for evey key.

I don't want to remap the "P" key, as I want the P key to work as a P key when I am typing!

User avatar
corpse
Posts: 34
Joined: Sun Dec 18, 2005 5:28 pm
Location: uk

Post by corpse » Sat Apr 15, 2017 12:40 pm

Hi,

Being as the issue only occurs when running scummvm through rocketlauncher, have you asked at their forum:

http://www.rlauncher.com/forum/forum.php

extracampine
Posts: 5
Joined: Tue Apr 11, 2017 11:46 am

Post by extracampine » Tue Apr 18, 2017 9:20 pm

Many thanks, I did and have sorted it it - it was an option in the ScummVM module for Rocketlauncher!

User avatar
corpse
Posts: 34
Joined: Sun Dec 18, 2005 5:28 pm
Location: uk

Post by corpse » Wed Apr 19, 2017 7:57 am

Glad to hear, its sorted.

Post Reply