Discworld doesn't start

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Ingsoc
Posts: 24
Joined: Tue May 31, 2011 1:52 pm

Discworld doesn't start

Post by Ingsoc » Tue Mar 21, 2017 5:48 pm

Hi,

I try to play Discworld in the CD Hebrew version and every time I try to start the game it fail to launch and throw me away to my desktop.

User avatar
envisaged0ne
Posts: 148
Joined: Mon Nov 01, 2010 9:17 am
Location: United States

Post by envisaged0ne » Tue Mar 21, 2017 7:44 pm

You might have your graphics mode or render mode set to something your computer doesn't like. Make sure you're just using default settings and no scaling. If that doesn't work, what non default settings are you using for graphics & sound options? Are you sure you have all the required files needed for ScummVM to run the game?

Ingsoc
Posts: 24
Joined: Tue May 31, 2011 1:52 pm

Post by Ingsoc » Wed Mar 22, 2017 9:09 am

Thanks for the reply.

Yes I've got all the files.

Use my regular setting: full screen, without any graphic mode or rendering, audio is also all set to default.

User avatar
dreammaster
ScummVM Developer
Posts: 368
Joined: Fri Nov 04, 2005 2:16 am
Location: San Jose, California, USA

Post by dreammaster » Wed Mar 22, 2017 12:36 pm

Ingsoc wrote:Thanks for the reply.

Yes I've got all the files.

Use my regular setting: full screen, without any graphic mode or rendering, audio is also all set to default.
Try running from the command line, and see if there's any explicit error. One common problem is that we updated the list of required files one or two releases ago to also include additional sound driver data. So if you've had the files copied off the CD for a while, you may still be missing them.

User avatar
criezy
ScummVM Developer
Posts: 550
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Wed Mar 22, 2017 8:40 pm

Also it would be useful to know what errors and warnings you get, if any. See FAQ 5.6 for an indication of how to see those messages.

Ingsoc
Posts: 24
Joined: Tue May 31, 2011 1:52 pm

Post by Ingsoc » Sun Mar 26, 2017 6:47 pm

I re copy the files from the CD and the problem still persist, run Scummvm from command line but still have no message would the game fail to load.

User avatar
dreammaster
ScummVM Developer
Posts: 368
Joined: Fri Nov 04, 2005 2:16 am
Location: San Jose, California, USA

Post by dreammaster » Sun Mar 26, 2017 7:48 pm

Ingsoc wrote:I re copy the files from the CD and the problem still persist, run Scummvm from command line but still have no message would the game fail to load.
That's weird. I can't think of any reason the game would just exit without giving at least some message. Maybe try looking at the scummvm.log file. You may want to consult the README, but off the top of my head, it's likely either in:
C:\Users\<your username>\Application Data\ScummVM\
or c:\Users\<your username>\AppData\Roaming\ScummVM

The log file will hopefully give you some clue as to why ScummVM failed.

Post Reply