scummvm 1.7.0 slows done whole system

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
fnatter
Posts: 3
Joined: Sat Nov 03, 2007 6:46 pm

scummvm 1.7.0 slows done whole system

Post by fnatter » Thu Nov 17, 2016 5:35 pm

hi,

I am using scummvm 1.7.0 on Debian jessie:
ScummVM 1.7.0 (Mar 1 2015 17:59:01)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG

and while playing Indy4 (FoA), the whole system slows
down significantly. This has previously not been the
case, since I have an i5 with 4 cores, lots of memory.

Which --debuglevel or --debugflags shall I set to
find out what's causing this?

Many Thanks and Best Regards,
Felix

User avatar
sev
ScummVM Lead
Posts: 1967
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev » Thu Nov 17, 2016 6:02 pm

It is not clear which sound driver you're using, or which gfx filter you run your game with.

1.7.0 is 2.5 years old (we released it in July, 2014. Can you try 1.9.0? Debian .deb files are downloadable from our site.

In general, there is nothing in SCUMM engine which could slow your system down. Indy4 was successfully working on as low as 20MHz systems, which means that in your case you should hardly notice any CPU usage.

What could potentially slow down, though, is MT-32 emulator (though that runs on single core), or graphics updates which we do via SDL. That old SDL could misbehave on modern OSes.


Eugene

fnatter
Posts: 3
Joined: Sat Nov 03, 2007 6:46 pm

Post by fnatter » Sun Nov 20, 2016 10:03 am

hello Eugene,

thanks for the answer. I tried again yesterday and
today and couldn't reproduce it. So it probably was
a one-off.

Thanks and Best Regards,
Felix

Post Reply