Help Regarding End Song in King's Quest VI

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
St_Eddie
Posts: 3
Joined: Fri Nov 04, 2016 2:18 pm
Location: UK

Help Regarding End Song in King's Quest VI

Post by St_Eddie » Tue Nov 15, 2016 4:03 pm

Greetings,
I'm thinking of replaying the King's Quest series again quite soon (my second time) and I was hoping that before starting, someone here might be able to help with a rather annoying problem...

The last time that I played through the series (via ScummVM - using the files from my official King's Quest Collection CD-ROM); when it came to completing King's Quest VI, the end credits were silent. It seemed a bit odd but then I later found out that a much loved song, titled 'Girl in the Tower' was supposed to play over the credits!

I can recall previously looking up some information on this and if my memory serves me correctly; the issue lay with the specific collection that I own. Does anybody here have any knowledge of a work around?

Also, if somebody here could send me a ScummVM save file from just before the end of the game, so that I can test any potential solutions (to check if the song plays or not - my previous playthrough was on my old computer, along with my previously saved states), then that would be very helpful indeed.

Any and all help would be greatly appreciated.

Many thanks.
Ed

EDIT: In case it helps, here's the exact cover art for the collection that I own (UK release)...

Image

...An interesting bit of triva; the various collections released for Sierra's classic adventure games during this period were somewhat notorious for being incredibly sloppy and half-arsed. I believe my Police Quest Collection didn't contain some of the relevant copy protection material (I had to resort to downloading it from the Internet).

EDIT 2: I found some interesting information regarding the issue on the forum over at GOG...

https://www.gog.com/forum/kings_quest_s ... tower_song

Have a read through that page and it's claimed that the issue lies with ScummVM itself. There's also a post with a link to a solution over at the Sierra Help Pages. When I attempted to open said page, I was informed that I needed to be a registered user to access the information, so I did just that and registered (which required me to have to wait for a moderator to validate my registration). Once I was finally registered, I once again attempted to access the relevant page, only to be told that I'm "not authorised to read this forum". For Jiminy Cricket's sake!

Please can somebody help me out here. I really want to replay the King's Quest series but I refuse to play a compromised version of King's Quest VI. I didn't even get the musical reference to the Girl in the Tower track in the third episode of the recent reboot until someone else pointed it out to me! I feel as though I'm being deprived of one of the highlights of the entire series here!

EDIT 3: The issue has now been resolved (see below).
Last edited by St_Eddie on Sat Nov 19, 2016 2:31 am, edited 1 time in total.

digitall
ScummVM Developer
Posts: 979
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall » Wed Nov 16, 2016 11:13 am

That should have been fixed since ScummVM release v1.7.0.

See:
https://github.com/scummvm/scummvm/blob ... .cpp#L1584

What version of ScummVM are you running? Try the datafiles with the latest v1.9.0.

St_Eddie
Posts: 3
Joined: Fri Nov 04, 2016 2:18 pm
Location: UK

Post by St_Eddie » Thu Nov 17, 2016 5:34 pm

digitall wrote:That should have been fixed since ScummVM release v1.7.0.

See:
https://github.com/scummvm/scummvm/blob ... .cpp#L1584

Thank you kindly for your response. That's interesting.
digitall wrote:What version of ScummVM are you running? Try the datafiles with the latest v1.9.0.
I've recently installed v1.9.0. of ScummVM on my new computer. When I last played King's Quest VI, it was on my old pc and it's possible I was running a version of ScummVM where this issue had yet to be resolved (approximately 3 years ago). Hopefully, the end credits will work properly this time around.

However, I'm still keen to test it out first, so I'd really appreciate it if you or anyone else on this forum could possibly send a saved game my way, from the end, or near to the end of the game?

Many thanks.
Ed

St_Eddie
Posts: 3
Joined: Fri Nov 04, 2016 2:18 pm
Location: UK

Post by St_Eddie » Sat Nov 19, 2016 2:30 am

With thanks to a user named 'albadross', I have received a saved game state and can confirm that the song now plays at the end of the game as it should. So indeed the issue lay with a problem existing only with older builds of ScummVM.

I wish to extend my gratitude to 'digitall' and 'albadross' for their help.

User avatar
m_kiewitz
ScummVM Developer
Posts: 157
Joined: Tue Dec 01, 2009 10:09 am
Location: Daventry

Post by m_kiewitz » Sun Nov 20, 2016 8:35 am

The code change, that got posted, only fixes it in Dual-Mode (speech + text at the same time, the original game did not support that). I'm not sure, but it could have been that originally MIDI music played instead.

Which makes me assume that it could also be that there was some issue with CD-Audio playback. Have you ripped the track from the CD? You should save it as Track1.mp3/.wav/.ogg and put it inside the King's Quest 6 main directory. Otherwise ScummVM needs to play it directly, which means the CD needs to be inside the drive.

Please also make sure that you enable the hi-res portraits. They are really nice and ScummVM should default to use them, when you add the game freshly.

Post Reply