Scummvm on rpi 3

Discussion about other and unofficial ports of ScummVM

Moderator: ScummVM Team

Post Reply
Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Scummvm on rpi 3

Post by Mia » Wed Apr 13, 2016 9:23 am

Hello all.

I'm trying to make scummvm on raspberry 3 work.

I have downloaded and unpacked th3 .tar.gz file, and followerd the raspberry specific instruction. Finally, scummvm works, with a primary problem:

I do not hear the "speeches" in game. Music works, but nothing about speech. No matter what I set it to (speak only, text, text and speak)

When I sudo apt-get install scummvm on the raspberry pi, both speech and music works at the same time, butt that version in the repo is older (1.7.0) therefore it has issues with going fullscreen on my 800*480 hdmi display.

So I'm here asking you what might be the reason.

Cheers

User avatar
sev
ScummVM Lead
Posts: 1967
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev » Wed Apr 13, 2016 9:25 am

If the game which you're using has re-compressed music/speech, then it might be any of MP3/Ogg/FLAC, which will require relevant library to be compiled with ScummVM.

If you're using uncompressed original, still depending on the game you might require MP3 or Ogg.

Which game is that, and was it compressed or not?


Eugene

Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Post by Mia » Wed Apr 13, 2016 9:28 am

Tried indiana jones and the fate of atlantis, and dott. Both have the same issue.

They both work fine (sound/speak-wise) on 1.7.0 in the repo.

Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Post by Mia » Wed Apr 13, 2016 10:17 am

What are my options at this point?
How can I pinpoint the problem, and solve it?

User avatar
sev
ScummVM Lead
Posts: 1967
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev » Wed Apr 13, 2016 10:30 am

Are they originals or were recopressed?


Eugene

Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Post by Mia » Wed Apr 13, 2016 11:02 am

Downloaded from this website, first thing that comes up when you type "download scummvm games" really
Moderation: Link to warez site removed

edit: for some reason the url did not seem to work.
Just copy and paste the whole thing

Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Post by Mia » Wed Apr 13, 2016 12:45 pm

Since building of the SDL2 is the only not-so-basic step in the downloaded package readme_raspberrypi file, I assume this is about it, somehow.

When I followed the instructions initially, and made the sdl build, the cursor was stuck at the top left corner.

At the official raspberrypi blog, exactly at this link
https://www.raspberrypi.org/blog/scummv ... pberry-pi/ at coments, section, a user named "cameron" has this comment:
On top of the default Raspbian install I needed to install a couple more packages before building libSDL:
sudo apt-get libasound2-dev libudev-dev
libasound2-dev was required to get ALSA (sound) support and libudev was required for the mouse to work when running ScummVM from the console.
After reading this, I tried doing the mentioned apt-get install and, after making the make -j4 and sudo make install once again, the cursor was working.

So maybe something is still missing from the readme file. And -whatever-that-is could be causing this issue.

I'm sorry, as I'm a casual hobbyist about raspberry rather than an engineer level technical person. This is as far as my guesses can go, with the technical information I currently have.

If you like to see certain files/logs to find out what this is all really about I'd love to find and send those logs, if it's going to help.

vanfanel
Posts: 16
Joined: Sat Dec 15, 2012 11:14 am

Post by vanfanel » Thu Apr 14, 2016 1:44 pm

@Mla: I am the one who did the Raspberry Pi package.
I have both DOTT and Atlantis working here without any issue.
No particular compilation flags were used for the released executable, and according to the Raspberry Pi kernel and tools devs, the resulting executable should work on both Pi and Pi2.
It has been tested on Pi and Pi2, that's what I have.
I don't know it the Pi3 is any different, but I can not see any specific cross-compiler added to the official Raspberry Pi tools repository (https://github.com/raspberrypi/tools).

Do you have a Pi1 or a Pi2 to test? If it's a Pi3-related issue I can not do much for now.

Mia
Posts: 6
Joined: Wed Apr 13, 2016 12:24 am

Post by Mia » Fri Apr 22, 2016 10:41 am

it does work on all devices, in the way I explained above.
the sudo apt-get install scummvm install a version that works perfectly (about the sounds) however the resolution/scale is not working well (no matter what I tried, fullscreen is not possible)
The one I download here and compile myself is working, resolution wise, but the speech issue I explained above happens.

So there is a problem on both version.

Do your version work perfectly on a rpi and rpi2 with speech AND fullscreen scaling?

vanfanel
Posts: 16
Joined: Sat Dec 15, 2012 11:14 am

Post by vanfanel » Sat Apr 30, 2016 2:42 pm

Mia wrote: Do your version work perfectly on a rpi and rpi2 with speech AND fullscreen scaling?
Yes. Get a Pi or a Pi2, or borrow it, and see for yourself.

User avatar
md5
ScummVM Developer
Posts: 2258
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Sat Apr 30, 2016 7:25 pm

You seem to have downloaded the game illegally off some warez site. We don't know if the game files are compressed, or damaged in some way. Please go buy the game

Micha1982
Posts: 8
Joined: Sat May 16, 2009 4:20 pm

Post by Micha1982 » Mon May 16, 2016 4:07 am

Hello Vanfanel,

your release does not work for some more users as you can see in the comments under the release:

https://www.raspberrypi.org/blog/scummv ... pberry-pi/

Can you please tell us how to get it to work, please?

It freezes here on the menuscreen, my mousepointer does not move at all, it freezes completely. I can't do anything else than remove power (which is for sure not the best way to shut the Pi down).




Is it possible for someone to implement a fully functional (sound, scaling...a normal 'as it should' working) and actual version to the Pi's repository, please?





Btw,regarding sound @md5:
Years ago I made a shrinked/packed version from my (officially bought!) original game for use in ScummVM (which is possibly not allowed, too)for myself - what I want to point out is, that a packed version does not mean 'illegally downloaded' in every case - there are some users doing this to just save space (my game was 1/4 the size than before). However - a new release should work the same as other ones - and should not miss some functionality.

vanfanel
Posts: 16
Joined: Sat Dec 15, 2012 11:14 am

Post by vanfanel » Tue May 17, 2016 1:43 pm

@Micha1982:

-What exact version of SDL2 are you using? Have you built and installed SDL2 version 2.0.4?
-Have you installed the libudev development libraries (libudev-dev package in Raspbian) before building SDL2?
-Asuming you're using Raspbian, what are the contents of your /etc/udev/rules.d/99-com.rules file?

The released version is a fully functional version, with perfectly working input and hardware scaling using SDL2 (which in turn uses a GLES2 renderer that works perfectly well on the Pi), and contrary to what your comments over raspberrypi.org seem to suggest, I know what I am doing.

Micha1982
Posts: 8
Joined: Sat May 16, 2009 4:20 pm

Post by Micha1982 » Sat Jun 25, 2016 1:45 pm

Its a while ago now, but as written in the comments:

At first I have a Raspian-Os, Kodi and Retropie are installed, too.
When I am not completely wrong, someone (Jools) wrote or linked that there is a possibility that building SDL 2.04 may affect controls in Retropie, is that correct?


My second problem is, how do I find out if building SDL 2.04 was successful and is working/installed correct? after sudo make install, is there anything we need to do? Raspbian's softwaremanager showed as marked package ‘libsdl2-2.0.0-2.0.2+dfsg1-6’…shouldn’t it be something with 2.0.4 (after sudo make)? I got no errors when I've tried it, but it did not work at all.


Great that YOU are know what youre doing to get your 'release' to work - others not. So please let us participate...Mia, Galactic, Richard, me....minimum 4 people where it does not work, everyone of us with the same problem. What you released is definately not a fully functional version - maybe on your modded OS - but not for others using a normal Raspian and not have the knowledge to modify parts of an OS or its libraries by thereself ;)

Its a release for 'pros' only, not suitable for the 'masses' in my opinion / not working 'out of the box'.



Isn't it simply possible for you to update necessary files for ScummVM in the repository, or better change your release to work with the OS its 'official' libraries?


A good release should be installable with 'apt-get install scummvm' from repository and thats it in my opinion. However, how do I check if SDL 2.0.4 and EVERY other necessary file for your release is installed and working as it should?

Post Reply