ScummVM 1.8 on Nokia N810

Subforum for discussion and help with ScummVM's Maemo (Nokia N800/N810/N900) port

Moderator: ScummVM Team

Post Reply
the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

ScummVM 1.8 on Nokia N810

Post by the-force » Thu Mar 10, 2016 8:45 am

I would like to install ScummVM 1.8 on my Nokia N810. However, during installation an error occurs, that libmpeg2-4 is not installed. Where can I find the necessary files?

Regards
Stephan

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Thu Mar 10, 2016 1:34 pm

Do you have the Maemo-extras repo defined?

Is this a new problem in 1.8.0? (Do 1.6.0 & 1.7.0 install ok?)

the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

Post by the-force » Thu Mar 10, 2016 1:48 pm

Maemo-extras repo is defined but cant't find libmpeg2-4 there. Installing ScummVM 1.5.0 from repo works. I have not tested 1.6.0 or 1.7.0.

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Thu Mar 10, 2016 1:58 pm

It is listed in the extras repo since 2010
http://maemo.org/packages/view/libmpeg2-4/

Not sure what the problem is, maybe you need to apt-get update?

How are you installing the 1.8.0 deb? (Start with: "I downloaded it from the scummvm.org website downloads page)

the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

Post by the-force » Thu Mar 10, 2016 5:53 pm

Yes, I downloaded it from the scummvm.org website and tried to install it with the application manager...no success. I also tried to install the "libmpeg2-4_0.4.1-3maemo1_armel.deb" from your link...resulting in a message "package not compatible".

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Thu Mar 10, 2016 6:20 pm

You do have OS2008 4.1.2 (diablo) installed right?

the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

Post by the-force » Thu Mar 10, 2016 6:30 pm

OS2008 Version: 5.2008.43-7

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Mar 11, 2016 1:24 am

This is very very odd.

The only thing left to try (that I can think of) is to try to install it from the command line:

Code: Select all

sudo apt-get update
sudo apt-get install libmpeg2-4

the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

Post by the-force » Fri Mar 11, 2016 4:59 pm

Nothing happens when entering these commands (after sudo gainroot). Do you have a Nokia N800 or N810 and are able to test the installation of ScummVM 1.8?

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Mar 11, 2016 7:14 pm

the-force wrote:Nothing happens when entering these commands (after sudo gainroot)
What do you mean nothing happens? You should see a lot of activity after each of them. What is the output? Can you capture the output and paste it on pastebin (or similar)?
the-force wrote:Do you have a Nokia N800 or N810 and are able to test the installation of ScummVM 1.8?
I don't have an N800 but I've tested it on my N810 and it works for me. As part of the release, I've installed the ScummVM deb file and launched a few games to quick-test if everything works.

the-force
Posts: 6
Joined: Wed Mar 09, 2016 11:15 pm

Post by the-force » Sat Mar 12, 2016 8:26 am

I know there should be any activity but nothing happens. I'm also surprised that I can use gainroot without installing anything before. Maybe I have activated the RD mode. I will reflash my device and see if it helps. Thanks so far.

Post Reply