Unable to get my games to run on my Nokia 6600 (with sound)

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
User avatar
iedutu
Posts: 23
Joined: Mon Oct 31, 2005 8:12 am

Unable to get my games to run on my Nokia 6600 (with sound)

Post by iedutu » Mon Oct 31, 2005 8:19 am

Hi!

First, thanks a lot for this great release and this fabulous port!!
Now, I might be too of a rookie to use it, but it seems that out of three LA games, I cannot play any of them with sound.

All three games are fine (they work on my PC with the Windows ScummVM release 0.8.0 version) without any glitches.

I am getting an error (same for all three games) when starting the games. Details here.

I have tried using different music_driver settings: auto (default), adlib, windows, pcspk. No luck with either of them :cry:.


I have a Nokia 6600, using the release S60-V1 sis file.
This is my scummvm.ini file (from the mobile itself)

[scummvm]
FM_high_quality=false
FM_medium_quality=false
joystick_num=0
lastselectedgame=loom
music_driver=auto
music_volume=192
native_mt32=false
sfx_volume=192
speech_volume=192
subtitles=true
versioninfo=0.8.0

[loom]
description=Loom (English (US)/DOS)
language=en
path=E:\Games\Loom\
platform=pc

[monkey]
description=Monkey Island 1 (English (US)/DOS)
language=en
music_volume=192
path=E:\Games\MI1\
platform=pc
sfx_volume=192
speech_mute=false
speech_volume=192
subtitles=true

[monkey2]
description=Monkey Island 2: LeChuck's revenge (English (US)/DOS)
language=en
path=E:\Games\MI2\
platform=pc


Please let me know if I am doing something wrong here ... as I do not have sound for any of these 3 games.

A working 6600 .ini file would be great (just the scummvm tab)!!




Thanks!
Cristian.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

There is big issues with the soundhandling

Post by Anotherguest » Mon Oct 31, 2005 9:27 am

With Symbian S60 V1 devices, as it is very timing sensitive. This means that you should set the music driver to NO music.. and this will retain sound fx, but will not play any music. I have managed to get sound from my n-gage, but sometimes you need to reboot your phone between games.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

But I have also heard

Post by Anotherguest » Mon Oct 31, 2005 9:34 am

That the 6600 is extra extra sensitive about the sound timing, and can very easily crash if something is wrong. This is something I have been trying to work around, but still is not 100% perfect. I might release a version without any sound support to remove the crashes

summer
Posts: 2
Joined: Mon Nov 07, 2005 12:09 am

Post by summer » Mon Nov 07, 2005 12:20 am

I've only installed monkey island 1 on my 6600 and the only way i managed to get it work was by setting music_driver to null in scummvm.ini file.. this is how my scummvm.ini file looks like without the individual gamesettings that you get when you add a game:

[scummvm]
aspect_ratio=false
enable_gs=false
FM_high_quality=false
FM_medium_quality=false
fullscreen=true
joystick_num=0
lastselectedgame=monkey
multi_midi=false
music_driver=null
music_volume=192
native_mt32=false
savepath=E:\System\Apps\EScummVMS60\
sfx_volume=192
speech_volume=192
subtitles=true
versioninfo=0.8.0

There will still be an error when you start the game.. Just ignore that..

I sure hope the soundproblem is fixed som day

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Nov 07, 2005 9:25 am

I have found a solution for the problem I think. At least it seems to be very much more stable right now. Watch anotherguest.b0.se for cvs updates.

Post Reply