ScummVM with libSDL 2.0?

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
shmerl
Posts: 19
Joined: Mon Aug 05, 2013 12:49 am

ScummVM with libSDL 2.0?

Post by shmerl »

Currently ScummVM uses libSDL 1.2. It's already becoming EOLed, and with Linux moving to Wayland, only libSDL 2.0 will be supported there. There are new mobile Linux distributions coming out this year which will ship with Wayland only. For example Jolla's Sailfish which will be shipped with their upcoming device in the end of 2013. It will support libSDL 2.0 (but possibly not libSDL 1.2). Same thing with Nemo Mobile and future Plasma Active.

Are there any plans for ScummVM to start using libSDL 2.0? This would enable porting it to these new systems.

User avatar
md5
ScummVM Developer
Posts: 2261
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

There has been a discussion about it on IRC, on May 9, 2013:
http://echelog.com/logs/browse/scummvm/1368050400

Start reading from 19:45:27 onwards.

One of the weird things they did in SDL2 was to completely drop CD-ROM support for all platforms, without supplying some sort of a replacement.

In short, there isn't any compelling reason to move to libsdl2 yet, but AFAIK, ScummVM *should* compile for libsdl2 (take this with a grain of salt), since some of our ports, like the PS3 port, are compiled against it.

shmerl
Posts: 19
Joined: Mon Aug 05, 2013 12:49 am

Post by shmerl »

I kind of understand that, since CD-ROM is becoming increasingly pointless feature for future development, but it's needed for legacy purposes. I guess SDL didn't want to maintain it.

Staying with SDL 1.2 isn't an option long term (for example it doesn't support EGL, and Wayland uses EGL, not GLX). The last time I tried to build stock ScummVM against SDL 2.0 it didn't really work. I'll give it another try.

From that discussion:
[20:17:45] <[md5]> we do have a separated CD-ROM manager
[20:18:09] <fuzzie> but someone'd have to come up with a good reason for moving to SDL2 first
There is a good reason now - Wayland only distros.

fuzzie
ScummVM Developer
Posts: 178
Joined: Mon May 24, 2010 3:02 pm

Post by fuzzie »

shmerl wrote:There is a good reason now - Wayland only distros.
If you're using a Wayland-only distro then you're deliberately making life difficult for yourself and choosing to not be able to run apps..

And the SDL2 APIs have changed so we don't build against SDL2 at the moment. As I said on IRC it's totally not a priority for us at the moment.

shmerl
Posts: 19
Joined: Mon Aug 05, 2013 12:49 am

Post by shmerl »

Developers of systems like Sailfish and Nemo made such decision (i.e. to drop X11). I think it's actually good for pushing Wayland forward. The desktop will follow at some point, so it's up to you to decide when is the tipping point for enabling support.

shmerl
Posts: 19
Joined: Mon Aug 05, 2013 12:49 am

Post by shmerl »

As an update, it looks like someone attempted to build ScummVM with Wayland and libSDL 2.0 for Nemo Mobile:
build.merproject.org/package/show?package=scummvm&project=nemo%3Adevel%3Aapps

Post Reply